ee Inspiration Theme - Nonfunctional Links

  • Problem
  • Updated 3 years ago
I did a clean installation of ee & the Inspiration theme, after that, i did have some error messages, but it was due to the fact that i did not had created the cache file in the server, after doing that, the error messages dissapear, but the links are not functional in the site, here is the site link:

http://www.sanquintinonline.com/#

Thank you very much for your help and support.

JJ
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes

Posted 3 years ago

  • 1
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
Hi JJ,

seems like this is a problem with your EE setup, please have a look at the top of this Troubleshooting FAQ: http://bit.ly/uewMem
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Dear Bjorn, thank you very much for pointing me to the solution, i followed the step by step guide and finally managed to get your template working.

Again, thank you very much for all your help and support... also your patience!

JJ
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Bjorn, a quick question, how do i change the logo that cames with the inspiration template with mine?
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
The easiest is just to replace the image via FTP:

/themes/site_themes/inspire/images/logo.png
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Thanks again!
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
No worries, good luck with your site:)
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Bjorn, sorry, questions rise as i am working on the customization of the site, on the "frontpage info" section, you placed some pretty cool "Read more" buttons, that seem to link to the rest of the article/story, but the problem is that, none of them seem to link to any view/full article page.

Can you tell me how can i do this, i have scroll all over the "frontpage info" articles and they are all the same.

Again, thank you very much for your great and excellent support.

JJ
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
If you have a look in the entries published in "frontpage info" you'll see they include a field called "Link". These are all set to "#" by default, so you'd want to set to e.g. "/about" for an about page, etc.
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Oh, i see, let me give it a try, thank you very much for your patience.
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Hi Bjorn, still dealing with the links, i was wondering why the Blog section was not working, it the main menu, i was clicking on the Blog Section Link and yes, this was sending me to the Blog section, but once there i was clicking on the entries you made for this section but it was not working.

So i thought maybe you just placed dummy links, then i went to the entries section and saw the actual entries posted, so took a closer look at the links and found this:

http://www.sanquintinonline.com/index...

So, i went an add the '?' so the link will look like this:

http://www.sanquintinonline.com/index...

And it worked, tried a couple times more and yes, it is now working, but, my question now is,how can i fix this so the links automatically have the '?' sign so the Blog section works as it is supposed to work?

Thank you very much for your help Bjorn, and sorry for any inconvenience this may cause you.

JJ

PS: To say it clear, main links are working, the links on the menu, but the links within the blog, these are not working due to the absence of the interrogation sign.
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
The setting which adds the "?" is called "Force URL Query Strings" which you have enabled on your website. If you can turn this off and still have your website working I would do that (better links): http://ee.bybjorn.com/l/user_guide/ge...

If not, in the backend navigate to Admin -> Channels and then click "Edit Preferences" on the Blog channel. Change the "Comment Page URL" under "Path" to include the ?. Do this for the Videos channel as well.
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Dear Bjorn, that did the trick, thank you very much for your help and support, i will continue customizing the theme, thank you very much.

JJ

PS. Are you planning on delivering more themes for ee some day in the near future?
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
No worries .. about future plans I do not have any immediate plans for more themes but you never know, I might. I've just created a "how to create an expressionengine theme" video tutorial for a site called tuts+ so hopefully that will help more people relase EE themes on ThemeForest and sites like that. :-)
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
Good to hear that, Bjorn now i have another problem, well with the metadata, on every post i made, the metadescription appears just fine, but on the main site(index), it doesn't appear, all i get is a 'Your description goes here...'

I have placed the text on the Add ons>Modules>SEO Lite section, i have placed my keywords and site description on the indictated fields, but this information does not appear.

Is there anything else that needs to be done?

All the best,

JJ
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
You can edit the default SEO Lite settings in Addons -> Modules -> SEO Lite.

The homepage is where it would make sense to show the defaults.
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
:$ Bjorn, it's me again, I'm trying to use the Adsense section from the WooThemes Control Panel, but i have question, i can see 3 fields:

Adsense code, Banner Ad Content - Image Location & Banner Ad Content - Destination.

I add my adsense code in the 'Adsense Code' Section, but i don't get to see anything displayed,

Now, the adsense comes with 2 code pieces, the one with the client id, and the one with the show_ads.js.

Does these goe togheter in the same adsense code field or should i placed them in somewhere else?

Thank you very much for your help, patience & great support

JJ
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
You'd need to put in all code there that is required for the adsense to show. So, that means all code you find when you click the "Get code" in your adsense account .. (so both 2 pices).
Photo of JJGarciaJ

JJGarcia

  • 11 Posts
  • 0 Likes
mmm... something may be wrong because, its not working, i guess i will have to wait a little longer to see if this has something to do with adsense or something like that.

Bjorn, i like the blog and it's functionality, is there a way i can have something just like that but for videos?
Photo of Bjørn Børresen

Bjørn Børresen, Company Admin

  • 1127 Posts
  • 39 Likes
If your website is not approved for AdSense then ads will not show up until it is ..

As for videos you could basically replicate the templates found in /blog/ into a new template group called videos and maybe create a new channel for it as well to have a section like that only for videos.