Being prompted to update Xpand!2

Hey mates! Whats up? I have a question. So I bought myself an Alesis V49 and with it came a free copy of XPand2! I downloaded it and preceded to install it and everything then when I was opening my DAW It says that it has to be updated. I use Garageband X and its a 64 bit DAW so its not that (not that i know of anyway) Xpand is also at 64 bit and AU compatible.... can anyone help me???!! Its really weird !!!
1 person has
this problem
+1
Reply