I’m frustrated

Crashes with Live and Authorize exes not working

Hi, i just got the air instrument expansion pack with The Riser.
Downloaded Hybrid, Vacuum Pro, The Riser, Loom and Velvet for now.
After installing them i rebooted my pc, then opened Live and changed the VSTs directory to the air instruments folder in program files(x86). Then, it crashes.
Already triyed to set the folder to each plugin separately, and them all crash, only the riser worked!
I noticed the installations created autorize icons for each plugin on my desktop, but when i run them, nothing happens. I tryed to open the executables themselves on their folders on Program Files, as administrator, but still nothing happens. The processes opens and closes themselves, when i look at the task manager.
Tryed reinstalling them, reinstalled the old and the newest Pace drivers..
I use Windows 8.1 64bits, Ableton live 9 32bits and the Pace drivers are 64.. maybe that's the problem? When i try to install the Pace 32bit drivers, it obviously doesn't let me do it.
(6GB RAM / enough hd space)
1 person has
this problem
+1
This topic is no longer open for comments or replies.