I’m frustrated

Installation issue for ALL airmusic plugins (riser, loom, hybrid 3 etc)

Hi

I can ́t install any of my airmusic plugins. Setup raises the following issue: "error 1935 - an error occured..." and refers to "Microsoft.VC80". This appears to relate to the VC++ redistributable.

The problem is that Microsoft released a more recent version (2017) and doesn ́t allow you to downgrade (to 2015). The new version is 100% backwards compatible. and developers are supposed to check the version and allow any higher versions. This doesn ́t appear to be the case for Airmusic plugins however.

A potential workaround is to de-install the more recent VC++ version, install the airmusic plugins, and then once again re-install the most recent VC++ redist. I have not tried this myself though as it ́s just too much of a hassle.

That means I can ́t currently install any of my 10+ plugins from Airmusic, and not open any of my existing projects with airmusic plugins in them.
2 people have
this problem
+1
Reply
  • This is what happens if you install the 2015 redist when 2017 is already installed:

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • And this is what the installation issue looks like (for "The Riser" in this case):
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I’m frustrated
    Below you ́ll find a snippet of the log file. This is for Loom2 but the problem is the same:



    In text:

    [1274:170C][2018-12-26T01:16:44]i301: Applying execute package: vcredist64.msi, action: Install, path: C:\ProgramData\Package Cache\{ad8a2fa1-06e7-4b0d-927d-6e54b3d31028}v8.0.61000\vcredist64.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7"'
    [1274:170C][2018-12-26T01:16:51]e000: Error 0x80070643: Failed to install MSI package.
    [1274:170C][2018-12-26T01:16:51]e000: Error 0x80070643: Failed to execute MSI package.
    [3358:066C][2018-12-26T01:16:51]e000: Error 0x80070643: Failed to configure per-machine MSI package.
    [3358:066C][2018-12-26T01:16:51]i319: Applied execute package: vcredist64.msi, result: 0x80070643, restart: None
    [3358:066C][2018-12-26T01:16:51]e000: Error 0x80070643: Failed to execute MSI package.
    [1274:170C][2018-12-26T01:16:51]i329: Removed package dependency provider: {ad8a2fa1-06e7-4b0d-927d-6e54b3d31028}, package: vcredist64.msi
    [1274:170C][2018-12-26T01:16:51]i351: Removing cached package: vcredist64.msi, from path: C:\ProgramData\Package Cache\{ad8a2fa1-06e7-4b0d-927d-6e54b3d31028}v8.0.61000\
    [1274:170C][2018-12-26T01:16:51]i326: Removed dependency: {931d3748-a95f-434c-9e73-207c86078e01} on package provider: {710f4c1c-cc18-4c49-8cbf-51240c89a1a2}, package vcredist.msi
    [1274:170C][2018-12-26T01:16:51]i329: Removed package dependency provider: {710f4c1c-cc18-4c49-8cbf-51240c89a1a2}, package: vcredist.msi

    You can clearly see that the installation program failed to install vcredist64.msi
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Hi Joakim,

    Thanks for posting. I will pass this information along to my software team for review for you.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Hi to all,

    I have the same problem on my new PC configuration (AMD Ryzen 2600, MSI m-board, 16gb memory) with fresh install of Windows 10 64 bit. All 5 of my AIR plugins worked fine on my old Win 7 64 bit platform, without any installation problems.
    However, this time all installations end with error message connected to VC++ 2005 package (not 2015):



    I downloaded MS VC++ 2005 runtime redistributable package (64 bit) and installed it without any problems, along other, never versions - they all sit happy along each other, as you can see from this picture:



    So, this is not Microsoft problem - but problem with all AIR installers. Infact, 2 problems:
    1. As Joakim stated somewhere else, AIR installers do not check existence of newer installed versions of MS VC++ runtime redistributable packages. Which is case of lousy programming.
    2. From first picture it looks like AIR installer correctly recognize system (amd64), but then tries to install wrong version (32 bit) of MS VC++ runtime package. That's my hunch, but maybe I'm wrong.

    Sadly, I like AIR plugins, but those installers are just not good...there is so many problems with them, and that Pace junk. Pardon me ;)
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I am running Windows 10 1803 (64-bit) fully patched through Dec 2018, and just installed AIR Loom and Riser without any issue or error messages. I have VC++ 2005, 2008, 2010, 2012, 2013, & 2017 installed.

    I used the installers that I downloaded a couple of years ago, and had previously installed on two Win 10 machines.

    Have you ever been able to run these installers? Where did you get the installers from and what is the file name and version?

    Unless this is an isolated conflict with certain machines, I would have to guess that the installer may have been updated incorrectly?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Yeah, I ran those installers on older PC (Win 7, 64 bit) without problems.
    On new one I tried several other things: Run as administrator, run in Win 7 compatibility mode, deinstalling last VC++ 64 bit package version - but with no success. I got installers from Plugin Boutique, or directly from AIR site (tried both).

    So, yes, it might be platform related installer problem: AMD Ryzen + Win 10.
    Will try with older installers - when I find them :)
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I’m frustrated
    Any update to this issue from AIR? I have do a clean install of windows. The Air plugins are the only ones I have an issue with. I have googled and tried all the Microsoft related fixes to error 1935 but no good.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned