Any ideas why I can't get Xpand!2 to sound when playing a MIDI keyboard direct onto a MIDI track in Reaper?

Any ideas why I can't get Xpand!2 to sound when playing a MIDI keyboard direct onto a MIDI track? I am using Reaper, I have done everything that I am supposed to regarding arming the track, activating monitoring etc. The track shows it is getting MIDI signal and other plugins sound. The plugin works fine on ProTools First and works fine on previously recorded MIDI on Reaper. Just not as a live plugin on Reaper.
1 person has
this question
+1
Reply
  • Hello,

    Thanks for the post. It sounds like you know what you're doing on how to open a VST in Reaper but just to make sure, here are the steps again. Make sure Reaper is in 64-bit mode too.

    How to open a VST in Reaper

    1. Create a new track.

    2. Click on "fx" to open the FX window.

    3. Click on "Add". REAPER will scan the VST directory listed in "Preferences (Ctrl+P) > FX Plug-ins > VST plug-ins" and display a list of the available plugins.

    4. Select a plugin and click "OK". REAPER will load the selected plugin into the FX chain.

    5. Close the FX window.

    6. Right-click on the Record button and select a MIDI input (MIDI devices are set in "Preferences > Audio > MIDI").

    7. Record-arm the track by clicking on the Record button.

    8. Click on the speaker icon to select Input monitoring.

    9. Play something from your MIDI keyboard to make sure you are receiving MIDI correctly.

    10. Press the Record button on the transport to start recording.

    11. When you have finished recording, press the Stop button. A window will pop-up asking if you wish to save or delete the recording.

    12. Assuming you've just recorded an awesome take, select "Save all".

    13. Click the Record button to dis-arm the track.

    14. Press Play to listen to your recording.

    15. Repeat at will.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Hi Chris! Yeah I've done all this several times and I still get no sound out. Please note - it works on previously recorded MIDI tracks and the keyboard plays other VSTs fine so I am clearly doing something right. It's just that Xpand2 won't let itself be played live from the keyboard. Could it be a conflict due to Xpand previously being installed with ProTools First?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • 1
    I have solved the problem - using Reaper there is sub-menu under choice of input . Opening the input dropdown I could see that the last option under input:MIDI is "map input to channel" - and of course the default is set to send the info back to the source. Changing this to the MIDI channel of the plugin solved the issue immediately!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned