I’m perplexed

Structure 2.0.10 takes forever - over 90 minutes to rebuild database / hanging?

I recently purchased IEP Complete.

In addition, this is a fresh build of OS X on my laptop.

System: MacBook Pro; 16GB RAM; OS X 10.12.5; Logic Pro X 10.3.1

I've got all the pieces installed and have started working through instruments - Hybrid, Mini Grand, Structure, etc.

My licenses are on an iLok 3 and that's been working fine for my other effects and instruments.

I encountered the Mini Grand issue with Mini Grand 2.0.7 (clicking/no sound); installed 2.0.10 - everything with Mini Grand is fine now.

Now on to Structure 2.0.10. I installed 2.0.7 and then the 2.0.10 update.

I started Logic, created a software instrument track and then brought up Structure.

I went to database and it said, something like new content found; rebuild database?
Yes, and then it said "Scanning /Applications/AIR Music Technology/Structure"

It's been like that for over 90 minutes.
CPU usage in Logic is a few percentage.

I've attached a screenshot.

Please assist. Thank you!

Rich
3 people have
this problem
+1
Reply
  • Hi Rich,

    Thanks for posting. 

    As Structure is a very big plugin, it can take a bit of time for all of the content to scan and load properly. Since this topic was posted, were you able to have Structure successfully scan the content?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Hi Bill:

    I stopped it after about 3+ hours. i have a fast machine with SSD drives. Logic Pro X can re-index all of it's loops, samples and content within about 3-4 minutes (that over 50GB of content).

    Structure as 41-44GB of content. It shouldn't take multiple hours.

    After I stopped it and restarting Logic and Structure, the database showed the factory patches ONLY. No samples, no parts -- not sure what the criteria is for the indexing of parts, but it clearly did not find the factory samples. I can successfully browse the factory samples, but there is something wrong with the database search.

    The factory patches work, content is being played, but the database is having issues. It's as if it can't search directories on OS X 10.12.5 or something like that.

    It seems others are having the same issues -- see the post on Structure 2.0.2 -- one guy let it run for over 6 hours.

    Can you confirm with development what works and doesn't work with the database functionality? i would be happy to work with support/development and narrowing down the issue.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Alright, let's have you get in touch with the Support Team for one-on-one assistance. Log on to www.airmusictech.com/support to contact the Support Team. You can find their contact information on that page. 
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Hi Bill -- I am trying a couple things. I'm going through the other instruments to make sure that I don't have other issues before contact support.

    There seems to be some issues with the 2.0.10 update. Matt mentioned the issue with a folder being in the wrong place (http://community.airmusictech.com/air...)

    So it seems that when you run the 2.0.10 Mac updates it drops certain folders in /Applications/AIR Music Technology instead of their respective folders:

    For Mini Grand:
    1) Move 'Presets' into 'Mini Grand'
    2) Move 'Midi Assignments' into 'Mini Grand'

    For Structure:
    1) Move 'Settings' into 'Structure'
    Sine wave shows up as it should!
    2) Move 'Imported Audio' into 'Structure'
    3) Move 'Favorites' into 'Structure'

    Ok... the file system is looking better.

    Will see if I can get the database rebuild/catalog working better.

    Bill - Will reach out to support if the database rebuild/search doesn't start working for me.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated