Structure 2.0.7 very slow to load patches

Windows 8.1 64 bit laptop

I have been running Structure 2.0.2 for a couple of years, and patch loading time has been acceptable. However, for the last couple of weeks, for no apparent reason - nothing changed on my system, Windows Updates switched off, etc. - patch loading is very slow:

Time taken to load String Sect Leg Vel:
AAX - (host Pro Tools 12.4) - 20 seconds
VST - (host Cantabile 3) - 45 seconds

I never had a reason to time this previously, but think it was taking 2-3 seconds.

I've updated to 2.0.7, but the slow performance is the same.

WIndows Resource Monitor seems to show that it is taking an awfully long time to read the relevant .big files for the samples. These are stored on a second, internal Crucial SSD (separate from my system/boot SSD).

The usual utiilities confirm that there is no issue with the SSD itself, as do day-to-day file operations on, and backups of, the disk - these are fast. The SSD is 1TB and has about 33% free space.

I am not having the same issue with Kontakt, which is a comparable plugin in terms of the amount of samples it needs to load.

I have also tried using a different folder on the SSD for the Structure Factory Library. (Actually, I noticed that although I had Structure 2 and the Structure 2 library installed, it was still using the old library. I renamed the old folder so it wouldn't be found, and directed Structure to the Structure 2 library folder.) This didnt improve performance either.

As I understand it, fragmentation is not relevant for SSDs. (And is unlikely to be an issue in any case. This disk is mainly used to install sample libraries once and then read them many times. There are not many writes to it otherwise.)

Switching "Use Streaming" on or off, or chaning the streaming buffer/max sizes, doesn't seem to make any difference. I have plenty of RAM, and am using Structure for live performance, so don't really want streaming switched on.

Any help or advice would be much appreciated!
1 person has
this problem
+1
Reply
  • Hi Danny,

    Thanks for posting. 

    Can you please provide me with your full system specs? Have you tried uninstalling and reinstalling the software? Do you experience this issue with any other AIR plugins?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned

  • Hi Bill

    I have uninstalled and reinstalled Structure 2 (including content), but no difference. I don't experience this with other AIR plugins..... but Structure is the only one that's heavily sample-based and therefore (presumably) need to do the most disk reads.

    There's nothing wrong with my SSD. (I've tried updating the SSD firmware, and swapping it out with another SSD.)

    When Structure is loading patches/samples, the average disk transfer rate seems to be about 10MB per second. The SSD is easily capable of 100MB or 200MB per second for random reads.

    I don't have any anti-virus software running.

    System spec:

    Molten Music Technology Performer XL (rebadged Clevo) laptop
    Windows 8.1 Pro (build 9600), 64-bit
    CPU: i7 2.7GHz quad core
    RAM: 16GB
    System drive: Kingston HyperX 250GB SSD
    Samples drive: Crucial MX300 1TB SSD
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned

  • Alright, let's have you get in touch with our Technical Support team for one-on-one assistance with this. Log on to www.airmusictech.com/support to contact the Support Team. You can find their contact information on that page. 
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned