I’m sad

Structure 2 AU doesn't work in macOS Mojave

It can't be seen in Logic Pro nor Ableton (AU).
There are too many of us with this problem.
I hope AIR will release an update soon.
Also 2.0.10 update breaks the database.
8 people have
this problem
+1
Reply
  • Hi Alexandru,

    Thanks for posting. 

    Structure is compatible with Mojave. Make sure that you've restarted your computer after installing to complete the installation process. 

    Does the plugin show within Logic's plugin manager? I've included some more instructions below that will walk you through some steps to try if Logic isn't seeing your plugins:

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • Hi Bill,

    Thanks for replying.

    I’ve restarted my computer after installing Structure and still doesn’t work.

    Only Structure5.1_x64 shows up in Logic’s plugin manager. The stereo one doesn't appear.


    • I’ve tried all three methods and it doesn’t work.

    • The other link is only for GarageBand but I still tried the Two Notes Sandbox Patch. Obviously, it doesn’t work.

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned

  • It's an old bug which has been around since at least the release of High Sierra and THERE ARE NO PLANS TO EVER GET IT FIXED. You need a vst wrapper like blue cat patchwork to run the vst version but beware, Structure STOPS loading patches when it exceeds a certain number of sub-patches even though they will only consume e.g. 2GB of ram and you have 32GB. I gave up on it months ago.

    Bill R. Are you even aware of how serious issues there are with Structure? Because you seem absolutely clueless about the fact that logic pro simply doesn't see the stereo version of Structure and only 5.1? I tested it on numerous configs and it occurs everywhere. So does the sub-patch limit bug. Those bugs existed a year ago with High Sierra and Logic Pro 10.3, they exist with Mojave 10.14.1 and Logic Pro 10.4.2 and they will be there long after we are gone. Sub-patch bug also occurs in Pro Tools 12 and 2018.

    There have been several threads on here about those issues with no solution on the horizon and no reasonable workaround. Don't feel offended, Bill, I mean no harm. I am simply pissed about the fact that I put money into this product and got essentially screwed in the arse by this crappy company. As did many others who also gave up on them.

    Such an amazing collection of instruments and so poorly executed. What a shame...
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned