Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

AKAI MPD232 interfering with Moog Minitaur controls

Hey guys!

I'm having a bit of a problem here, namely, whenever I remap one of the knobs of my AKAI MPD 232, it changes the decay of my Moog Minitaur. This happens only with the knob on the far right which has CC Number=019.

If I leave the knob's MIDI CHANNEL on COMMON, the MPD changes the DECAY of the Minitaur, if I change the MIDI CHANNEL it changes the CUTOFF.

If I use the PADS the Minitaur starts outputting a constant tone and I have to restart my PC or delete the mapping in Ableton.

SETUP: The Minitaur is hooked up via USB and I routed its audio out into my focusrite scarlett 2i2 interface. The MPD is hooked up via USB. I am using ABLETON.

I installed that editor from http://www.akaipro.com/products/pad-c.... Then I installed the midi updater and opened opened the firmware file but it just keeps asking me if I want to update the MPD232 constantly, no matter what I click (YES/NO).

Here are some screenies:

https://imgur.com/a/OwjbNGB
https://imgur.com/a/DnX74Ee
https://imgur.com/a/1OOu4Ij
https://imgur.com/a/4FSZfgd
1 person has
this problem
+1
Reply
  • Hey A C,

    Thanks for posting! Sorry you're having some trouble with that!

    I see that the Minitaur is configured to receive MIDI data from Ableton as an external MIDI device. Is your intention to pass MIDI data from the MPD to the Minitaur by means of Ableton's External Instrument function? If so, the MIDI data that is input from the MPD will go into Ableton on the channel you've assigned but the MIDI data leaving Ableton will be sent on whichever channel the External Instrument is assigned to.

    Have you tried assigning a different MIDI CC from that knob to see if it reproduces the same result? Have you tried using a different MIDI channel for the External Instrument track in Ableton?

    What is the MIDI implementation for the Minitaur like? Can you assign different channels or edit its parameters to be affected by different MIDI CCs?

    It also looks like the MIDI setup in Ableton might be generating a loop of data if the Track Input for the Minitaur is enabled. If you only intend on recording audio from the Minitaur and no MIDI, you won't need to enable Track Input (or really any input) for it in the MIDI menu in Ableton. Unless you are intending on sending MIDI data from the MPD to control Ableton, you won't need to synchronize Ableton to the MPD's clock. Take a look at the MIDI input/outputs in Ableton and make sure you're only sending data to ports that are necessary for what you want to do.

    Regarding the updater, you're likely already on the latest version of firmware but we can verify that easily from the Global menu. Press Global then press the right cursor button until you reach the last page, OS. The version field will indicate the firmware version on the MPD - it should be at 1.01.

    Check that out and let me know!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned