I’m sad

Can't install MPC 1.9 - Mac OS X 10.8.5 or lower

At this point i've red all the requirements and all that ...
Says for mac osx 10.7 or later wich i am, and for some reason it won't let me upgrade ...

i'm so disapointed

Any thoughts????
4 people have
this problem
+1
Reply