Help get this topic noticed by sharing it on Twitter, Facebook, or email.

EIE Pro/Mavericks static pops and cracks

I'm running Logic Pro 9 on a Mid 2012 Mac Pro. 2.5GHz, 8GB Mem OSX 10.9.3. EIE driver 2.2.5

I have tried your beta drivers to no avail and have fed back accordingly (also it seems to no avail).

I can use the EIE with its limited functions under the above driver but after 10 mins or so the pops/static start and I have to power down and restart. Looking at the threads, this is a common problem so all seems to point to your extraordinary inability to produce the required drivers for us. What's the latest on there being a proper, non-beta, release before I throw this thing through a window and go to a company that can provide me with what I need.

Thanks
2 people have
this question
+1
Reply
  • Hello,

    Thanks for posting. I'm sorry to hear you're having trouble!

    The latest drivers for the EIE Pro will be posted to the EIE Pro product page:

    http://www.akaipro.com/product/eiepro...

    There was a newer beta (b19) that was posted a couple of weeks ago. Had you tested with that as well? Any particular symptoms while using the beta driver?

    In regards to future releases, they are first announced on the Akai website. We will then notify the forums in our Updates section. In the meantime, we are unable to discuss the development or status of unreleased software here.

    Let me know if you have any questions and I'd be happy to help!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated