Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m anxious

I think the sound card in my MPC X just died!

Turned on the X today put my headphones on heard alot of noise when the jack was inserted. I also heard a lot of unfamiliar humming and buzzing. Checked the Yamaha headphones in the Montage... Headphones working.

So I loaded last nights work and .... Nothing. Hit play... Nothing ... play head did not move like the sequence was stuck in the same position. Started playing with the headphone volume slowly sweeping from low to high. At around the ten o'clock position I could faintly hear the song playing like trying to tune into a out of range radio station. As I swept past this position more flutter and hum and pops. I then heard a loud single pop (like bubble wrap popping) coming from the top right corner of the unit. No sound.
Tried to update the firmware again. Nothing.
Tried loading other programs... Same results.

Started saving all my projects to my internal Samsung SSD.

Opened up a Cubase program where the X was a plugin. Switched to controller mode, and successfully loaded a song.

So long standalone.
Called tech support but they were at a company picnic.

Hope this can be resolved quickly.

I have many things coming up next week and would like to make use of this monster...

Drum Gun
5 people have
this problem
+1
Reply