Help get this topic noticed by sharing it on Twitter, Facebook, or email.

MPC Essentials 64bit-VST-Plugin Problems under Reaper: Transport-Buttons not working

Hey everybody,

after upgrading my DAW "Reaper" and the VST-Plugin "MPC Essentials" to 64bit, i'm no longer able to use the transport buttons (play, stop, record, etc.) for controlling Reaper. The 32bit-Version worked perfectly.

Before you ask:
- yes, I installed the Akai Midi-Helper (only the 32bit-Version, though, since no 64-version exists?)
- yes, I configured the preferences within the essentials-software (Controlling DAW).

Please help!
1 person has
this question
+1
Reply
  • Hi Tosh,

    Thanks for posting!

    If you updated Reaper, you may just need to re-map the transport controls to Reaper. Start a new reaper session and open a plugin track with MPC Essentials.

    Go to the Repaer preferences and enable the MPC Element ports in the MIDI Devices section. Right-click on the device and "Configure Input" and make sure that "Enable Input for Control Messages" is turned on.

    After that, just follow Reaper's instructions to learn MIDI commands in their Action's list:

    http://wiki.cockos.com/wiki/index.php...

    I recommend using the search function to find the appropriate transport controls.

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Hey Corey,

    thanks for the reply.

    My Midi-Inputs were already enabled (even for control messages), and I am able to map the transporter-controls to the transport-section of reaper (play, record, and so on - thanks for the wiki-link). Four things, though:

    1.) I only receive midi-control messages from the "MPC Public Midi"-Channel. The Akai Internal Midi-Channel (the one from the helper-application) is dead.

    2.) That means, that I do not need the Akai Intermal Midi-Program for enabling the input-controls. I disabled the midi-helper (the appropriate midi-channel disappeared) and the mapping still worked.

    3.) When I connected my mpc element to the 32bit-Version of the programm (using the 32bit Internal-Midi-Helper-Program), I didn't need to configure anything (besides enabling DAW-Controlls within mpc essentials). The transporter-buttons were fully functional. But not with the 64bit-Version.

    4.) The transporter behaves weird, when controlled by the mpc element, using the manual midi-mapping. It seems, that the action gets triggered twice, when I press the respective button ("stuttered" play // the record jumps on and then off again, though I'd pressed once).

    From all these things, I conclude, that the 64bit-Versions of reaper / mpc essentials are not compatible with the 32bit-Version of the akai pro internal midi-software-helper. It seems, that the daw does not receive any signals from the akai midi-helper (though fully enabled). The way, I'm able to map the midi-outs right now does not seem the be the right method, compared to the functionality of the 32bit-Version.

    So, again I'm thankful for all replies!
    Tosh
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated