I’m frustrated

MPC IS UNRESPONSIVE!! (BRICKED REN)

MPC IS BRICKED!! HELP!!!!!!

Ok Its my first post here, and Im in DIRE need of some assistance. Yesterday i tried to update my MPC Ren's firmware. (On Windows 7 64-Bit, 16GB RAM--2TB HD) After sucessfully updating i was told that I may need to reset the MPC in order for the firmware to kick in. I power cycled and upon turning my MPC on again, i got nothing. Nothing but two red pads lit up, and the blue screen. Not even the MPC logo on the blue screen, just two red pads and a blue screen. I have tried everything....reset dozens of times, even tried to reinstall drivers and such, and it now seems that my computer wont even recognize that there is an MPC present....thats on any USB slot and with nothing else connected save for my mouse. I need to figure out whats the issue here. --and to complicate things, i am working and living in CHINA, so if i do need to get it repaired im at a loss as to how i am supposed to do that here in this country.

Im hoping someone out here can help me get this sorted as i want to get back to making good music. Again if i need to send in for repairs any assistance as far as where to do that at here in China or another nearby country would be great. Thanks in advance.
1 person has
this question
+1
Reply