Help get this topic noticed by sharing it on Twitter, Facebook, or email.

MPC X MIDI Clock jitter problem?

Hello Guys! I am experiencing a very weird phenomenon.

I guess I have found a bug. My related setup is an MPC X (with 2.3 firmware) and a DSI/Sequential Pro2. I only started to experience the following after 1.4 firmware was installed on Pro2. The phenomenon is that if I push any of the MPC’s function buttons, such as pad banks, channel mixer, pad mixer, etc, which normally don’t send any CC or NRPN messages (I have tested it with midi monitoring, they truly don't send them) while running a sequence, an unwanted sound appears in the current patch running on pro2 (e.g. an arpeggiator). It sounds like when you change between patches while playing. I guess you will know what I mean. As for the MPC: it’s sending MIDI Clock, without MMC and connected via normal MIDI to the Pro2 back and forth (first I used the USB going back to the MPC, then I changed to MIDI to eliminate the possible error sources and of course my MIDI cables are OK, but at the end I found that these don't relate to the issue).

The phenomenon only occurs when I put the Pro2 in slave mode. Without slave mode, the arpeggiator runs off from the beat, even if ARP BEAT SYNC is turned on, but I don't experience the phenomenon. I have tried turning on and off receiving and sending CC or NRPN messages, but neither this and nor the other setting options in the Globals of Pro2 seem to affect this weird sound effect. It only disappears when the Pro2 is not in slave mode (but then it becomes inaccurate). I also tried to plug out the midi cable going back to the MPC, but it also didn’t affect the presence of the weird sound phenomenon. I think I have tried almost every combinations, but seemingly this somehow relates to the Pro2 being in slave mode.

The other thing I encounter is that the BPM value sent from the MPC is changing in the Pro2 slightly, but surely in a 1 BPM range, constantly.

As I have discussed about this issue with the DSI/Sequential Support, they told me that after the new firmware update (1.4) the Pro2 clock receiving accuracy became much more sensitive, that's why it is showing the BPM changes in a 1 BPM range and also this is the cause (clock frequency mismatch, inaccuracy) of the sound phenomenon I wrote above.

Could you tell me please if you are planning to solve this clock problem.

Thank you!
4 people have
this problem
+1
Reply