Help get this topic noticed by sharing it on Twitter, Facebook, or email.

MPC X needs to fix major problems with data handeling!

Akai, you have to fix the data handling on the MPCX before the public release!

I am on my second MPC X since July 9th and I have had several issues with data and disks installed and connected to the unit.

Once on the first MPC X connected to my computer with around four external hard drives attached to it. I switched from standalone to controller mode and all my external drives attached to my computer were ejected unexpectedly.

Also on both my first and on my current unit...
When switching from controller mode back to standalone mode you are supposed to eject the disks that are in, or are attached to the MPC X. Typically when I eject a drive from Windows 10 pro 64 bit there is a confirmation message that lets you know that it is safe to now eject the disk.
When ejecting disks from the MPC X (the internal SSD drive and USB drive) roughly one in ten times did I get the confirmation that it is safe to eject the disk, but the disk would no longer be visible in the list of drives.

So I assumed that it was ok to remove the disks, and subsequently when the SSD or USB disks were visible to the computer it would trigger the scan disk to repair the disk message because it was not properly ejected.
I got this message allot on the first unit. Now on the second unit I am getting the same "not ejected properly" message even in standalone mode. A few times I received this message in standalone mode when creating a new project.

Also a MAJOR problem I experienced on the first unit that was probably caused by the above disk ejection problems...
I had to reload about 200 GB on my SSD that I fortunately kept on another disk! All the samples had just the front part of the wave, and all had blank space where the rest of the wave form should have been.

And finally on my replacement MPC X...
For my computer I have a backup system that consists of a WD Black Caviar 6TB in a external bay connected to a thunderbolt connection for a fast backup solution.
One time previous I had successfully put the MPC X in controller mode, and successfully backed up the SSD in the MPC X.
Three days ago I tried the same backup again and the master boot record for my 6TB was erased, and my whole back up disk looked blank!
Never had a problem with the backup disk, and did a scan for disk errors and there was nothing wrong with the disk!
The only new variable to my system is the MPC X.
And I have spent the last few days trying to recover the master boot record for my backup disk...

I've got potential MPC X purchasers watching me going through this with this NEW gear and are reconsidering. Quote "I'm a new producer and I will be making many mistakes... but I don't need my equipment making the mistakes for me".

Akai, as a experienced computer builder, and MPC user...this machine has not been consistent or very stable in regards to its data management. And I am disappointed that the expected UPGRADE to the Rennasaunce has new potential, but has me worried about whether or not these problems will be resolvable through software updates.
Please keep in mind that my first unit worked for a few weeks before the standalone sound generating capability failed.

Plus if this is what I'm going through as I experiment cautiously... I can't imagine if a user has been smoking and drinking and drumming!! (Like most sessions lol)
If not resolved these problems will cause a lot of unnecessary pain and suffering when released to the young and reckless. Or even to the seasoned user who just expects all the features listed on the box to work as advertised, but they don’t. Some features have yet to be implemented due to the Beta software that was shipped to those of us who signed up for the preorder.

Pushing the change mode button while in controller mode should automatically eject the MPC X by itself, from the system completely, and not show me a screen warning me about data loss if I don’t eject the disks right.
Make the code do the work please.
I would have preferred to wait for the finished product, but it is what it is.
It's hear, and I got it...

Let's make it what it should be.

Drum Gun

2 people have
this problem
+1
Reply
  • Hey Drum Gun,

    Thanks for posting!

    I understand that using substances for a little extra inspiration could lead to some confusion but you can't design a car specifically for a person that's had a few. We are just now coming up on the inception of self-driving cars - I think an MPC that will manage files for you is still a few years out ;)

    I have a few questions for you regarding your drive configuration - How are you connecting the four drives you're using? It sounds like you're connecting them to your computer directly but I want to make sure you aren't using a hub or something and connecting that to the USB port on the MPC.

    Aside from controlling the MPC Software, putting the MPC X into controller mode is effectively turning it into a card reader - the MPC could not eject a drive (or four) if they were not connected directly to the MPC hardware. Drives connected directly to your computer cannot be ejected by the MPC X. I suppose that your bus could have been overloaded with data or streched too thin for power if you have four drives and an MPC X in controller mode connected to it - this could have triggered all drives to be released but the MPC X itself does not have the capability to eject a drive that is not connected directly to it.

    When you're backing up your drives, how much data are you backing up at one time? Are you backing up up to 200GB (possibly with multiple drives) every time? If you're backing up this volume of files frequently, the root directory on this drive has probably seen a bit of action. When is the last time you formatted a drive to reset its root directory? What file system format are you using? Try formatting the drive the next time you're performing a backup.

    Regarding the MPC ejecting media by itself while it is in controller mode - the drive cannot tell the computer that it is going to eject - the computer must release the drive as it is the device that is hosting the drive. Since the MPC is acting as a reader, effectively "the drive", it wouldn't tell the computer that it is ejecting itself - the computer must release the drive.

    As far as your experiences when backing up your drives, it sounds like the data might not be passing through the computer itself? If your data is being transferred directly from a drive connected to the MPC hardware, it's transferring data directly from a USB drive to another connection type. If you are using a Thunderbolt (Thunderbolt 1 or 2?) connection for your backup drive, this is probably not the ideal configuration. I would consider connecting your drives directly to the computer and using your computer to back up all drives to the 6TB drive.

    I also want to make sure you are aware that a firmware update (v2.0.3) has been released for the MPC X and MPC Live. Drive disconnection is one of the points that is addressed with this update. Have you updated your hardware? I've created a guide that will walk through the process:

    Akai Pro MPC X and MPC Live - Firmware Update Walkthrough

    Be sure to update your firmware if you have not already done so and keep me updated with what is going on with your drives.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated