Alesis Multimix16 USB no line level control in Windows

When I hook my Multimix16USB (The blue one) up to my Windows 7 PC, I only get a mic level control in the Windows control panel. It is WAY too loud for the mic level in the control panel. How do I get windows to recognize this as a LINE level device?
1 person has
this question
+1
Reply
  • Hello Tom,

    Thanks for the post. I'd like to help! Try out this Windows configuration from below to help you out. Let me know how it goes!

    Windows Vista, Windows 7 and Windows 8 Sound Settings

    Recording Settings

    1. Click on the Recording Tab.
    2. Click on Microphone USB (Codec, PnP, Array).
    3. Click Set Default.
    4. Click Properties on the bottom of that window - Microphone Properties window will open.
    5. Click on the Levels Tab.
    6. Set the level to 5 (Windows 7) or 25 (Vista).
    7. Click on the Advanced Tab.
    8. Set the Sample Rate to 2 Channel, 16 bit, 44100 Hz or 44800 Hz.
    9. Uncheck both Exclusive Mode boxes.
    10. Click Apply, then OK to exit.

    * In some cases a restart is required to the level to save at 5 or 25 depending on your Windows version.

    * The microphone is very sensitive and needs be set this low to avoid distortion.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated