Cannot Detect Alesis Nitro Drum Module's MIDI with Computer and Audio Interface

I have searched other parts of the forums and have found no solutions to my problem. On my audio interface, I plug in the MIDI in and out to both appropriate places and do the same for my Nitro Kit. Normally, when MIDI devices are plugged in properly, the interface flashes whenever the MIDI is being sent out, but when I hit the kit, it doesn't happen. I have followed all the tips that are described for MIDI on the kit, like putting the GM and LOC on or off and I've also pushed the Start/Stop button to send the MIDI. The only thing that has worked is using a 1/4 inch cable, which obviously doesn't use MIDI (My audio interface is a M-Audio M Track Plus)
On my laptop, I've also tried connecting the kit through the USB connection. I don't understand how my laptop is supposed to recognize the drum kit just by use of the cable. Is there anything I have to download or should my laptop just recognize the cable sending MIDI? I have set up channel 10 on Presonus Studio One and it still doesn't show up, yes Presonus is a DAW. If it helps at all, I'm running on Windows 10.
4 people have
this problem
+1
Reply
  • Hello Cole,

    Thanks for posting!

    With the Nitro kit, you can connect the module directly to the computer via the USB cable for MIDI purposes. there is no need to use the 5 pin MIDI ports if you wish to use the USB cable. The USB cable is capable of MIDI input and output.

    Let’s run a test to see if the module is sending Midi Data correctly. These programs will let you know if and what MIDI information the controller is sending.

    • MIDI-OX version 7.0(Win): http://www.midiox.com/
    • MIDI Monitor(Mac): http://www.snoize.com/MIDIMonitor/

    Let me know how this goes!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned