Command Mesh Whine on Power off

Just purchased a Command Mesh Set. When I connect it to my church's sound system all is well. My issue is; I'm getting high to low pitched whine from the speakers shortly after the module is turned off. Reducing the volume before turning off the module doesn't help. Please advise.
1 person has
this problem
+1
Reply
  • Hello,

    Thanks for posting. Sorry you're having issues with your Command Mesh kit.

    It sounds like you may be experiencing an issue with your setup not being properly grounded. Check out this helpful link here that will walk you through how to properly ground your signal - http://www.audioholics.com/home-theat...

    If you're still having issues after going through this guide, you may need to service your product. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alesis Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited