DM10 Tom or Cymbals Hits At Same Time

I have a new DM10 Studio Mesh Kit.

When playing any 2 toms at the exact same time, only one will sound. If I slightly hit them off time (flam), they are both heard. I believe I have the latest updates on the DM10.

Trig OS: V1.00a
Sound ROM: V1.03
Sound OS: V1.00s

I have also verified all toms are set to Poly and MuteGroup is set to "OFF".

I changed the Category of one tom from Toms to Snares to see if that would change the behavior, but it didn't. It seems that the inputs of these 4 toms to the DX10 don't allow 2 hits at the exact same time.

I also have the same behavior with cymbals.

Thoughts?
1 person has
this problem
+1
This topic is no longer open for comments or replies.
  • Hello Ron,

    Thanks for the post. I'd like to help! It sounds like you're experiencing some crosstalk. Try out the directions below to help you out.

  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Hi Chris.

    I'll look at that tonight. However, I believe I'm experiencing the opposite of crosstalk. Isn't crosstalk when one trigger produces a sound when another trigger is hit due to vibration?

    In my case, when 2 toms or cymbals are hit at the exact same time, one of them simply doesn't produce sound. Only one of the sounds is heard. So I'm not getting extra sounds. I'm missing them.

    If I hit any 2 toms at the exact same time, I can produce the issue all the time. However, if I hit any tom and the snare at the exact same time, I hear both sounds all the time. Neither sound is missing.

    The same thing happens when I hit 2 cymbals at the same time. One sound is missing. And again, when hitting any cymbal with the snare, they are both heard all the time.

    Maybe another user reading this can try this out on their set to confirm if this is happening with them?

    Thanks,
    Ron
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Hi Chris.

    I think the Xtalk settings fixed my issue. The default values for all toms was 7 for
    Xtalk Send and Xtalk Receive. I adjusted both settings for all toms and cymbals to 4, and now I can hear both sounds at the same time. If I start to get crosstalk now, I'll adjust these higher. But for now, I think I'm good.

    Thanks!
    Ron
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated