DM6 recognized but not triggering in OSX Yosemite

Hi,

I have tried pretty much everything, but still cannot use my DM6 in Logic Pro X in Yosemite.

The DM6 is recognized by the OS (Audio Midi setup) and appears as e-drums, however I cannot edit the ports...

The problem is that somehow the triggers are not getting there. I tried the "test setup" and when I hit the pads nothing happens (the DM6 is in "--n" mode and I have performed several factory resets)

My korg usb keyboard works perfectly (triggers are recognized). I also tried deleting the midi configurations and rebooting, deleting the device and reconnect it, etc...)

Finally, I deleted and disconnected my keyboard and drums, then reboot and reconnect only the drums so it is the only detected device... but still no triggers...

Any help?

Thanks,

Alf.
1 person has
this question
+1
This topic is no longer open for comments or replies.
  • Hello Alfredo,

    Thanks for the post. I'd like to help! Keep in mind, resetting your kit is not going to help you in connecting in your module to your computer. That's mainly for resetting your triggers and kits. It appears your computer is reading your module so your software should to.

    To select the MIDI output format:
    * Press PATTERN to enter Pattern Select Mode.
    * Press VALUE +/- to select "P–N" (internal format, the default setting) or "– –N" (GM format).

    Here are your DM6 MIDI Assignments which can help you when your attempting to map your module to your Logic Pro X software.

    Kick - C1 - 24
    Hihat - F#1 - 30
    Crash - C#2 - 37
    Ride - D#2 - 39
    Snare - D1 - 26
    Snare Rim - E1 - 28
    Tom1 - C2 - 36
    Tom2 - A1 - 33
    Tom3 - G1 - 31
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Hi, thanks for the fast response!

    However, I already have been using the "GM" mode "--n" and still it is not working.

    The drum kit is recognized (see screenshot)


    However when I am using the "MIDI monitor" tool, it does not show any triggers.

    If I do the same with my korg keyboard it is both recognized and triggers are captured.

    For both I am using the same USB cable and port, so it is not the problem.

    Any other ideas?

    Cheers,

    Alf.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • I have the same problem and would really like to see a solution for it. I use Logic pro X and after pushing a lot of buttons one late night I got it working. However when I started it up the morning after I was back to square one and now I can't get any triggers at all!

    BR/Rob
    • Hello Robert,

      Make sure this is the only product connected to your computer via USB when you're using it. Try the creating a New Configuration under MIDI Studio.

      Here's what else you can try...

      Optimize Energy Saver
      This optimization will free up system resources as well as prevent the computer from going to sleep or standby mode which can cause hardware disconnections.

      1.) Open System Preferences.
      2.) Click Energy Saver.
      3.) Do one of the following (available option depends on your computer model):

      * Un-check the box for “Put hard disks to sleep when possible.” If present, set the “Computer sleep” slider to “Never.”

      * Otherwise, check the box that says “Prevent computer from sleeping automatically when the display is off.”

      Disable App Nap
      App Nap can negatively the performance of your software or DAW that processes audio or control changes. This is because App Nap considers any app that is hidden from view to be “idle.” It may then temporarily disable the app to free up resources which may cause clicks and pops as well as disrupt any processing that is happening in the background.

      To disable App Nap :

      1.) Go to your Applications folder.
      2.) Go to the App for which you want to disable App Nap.
      3.) Right-click or control+click the application and choose Get Info.
      4.) In the Info window, under General, you will see an option to prevent App Nap.

      Try all of this out and let me know how it goes.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited

  • Hi Chris,

    I tried everything in this post (and several others) and still no solution.

    The kit IS recognised as a USB Midi device when I plug it in, but the triggers are not getting to my MacBook.

    Please help!

    Cheers,

    Alfredo
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited