DM6 suddenly no snare, kick or tom2

Kit had been working fine. Today I turned it on and no tom 2, no kick, and only a really faint snare. Cables are all fine. This must be a fried module, right?
1 person has
this problem
+1
This topic is no longer open for comments or replies.
  • As a follow-on: switched the cables such that tom2 was hooked up to tom1. Tom2 still didn't work. So it's not the cables - must be the module. Any advice? Fix it, replace it? They're not sold any more right?
    • Hello,

      Thanks for posting. I recommend resetting your DM6. Power on, while holding the + and - buttons. This will restore the factory settings, erasing any recorded data or changed settings, including User Kits, the User Pattern, and any volume, metronome, or Voice settings, which will return to their defaults. If this doesn't resolve your symptoms then you may need to repair your module. Contact Alesis technical support if this is the case.

      Alesis Industries World Headquarters (United States Office)
      Support Contact: 401.658.3131

      Alesis UK LTD (United Kingdom Office)
      Support Contact: +44 1252 896040

      InMusic GmbH (Germany Office)
      Support Contact: +49 2154-81299-20/-25

      Alesis Japan Corporation (Japan Office)
      Support Contact: +81-3-6277-2231

      Alesis South America (Brazil Office)
      Support Contact: +5511 - 3222-6476
    • That worked!!! Thanks!!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated