I’m not even mad, i knew this product may be some bull***t.

GuitarLink Plus - Beeping Noises - OSX 10.11

Okay i'm really annoyed so I'll make it clear. I bought my GuitarLink Plus, installed all drivers, made an aggregate device and the sound from cable is awful. Noises and beeping won't let me even play one note. I'm using OSX 10.11, tried to take this issue to the music store that i bought it from but the cable was absolutely fine with their sony vaio. I don't get it, maybe the drivers are not provided or something. I won't write the details unless someone respond.
3 people have
this problem
+1
Reply
  • Hello,

    Sorry to hear about your issues. I'd like to help! Since it works on the Sony computer, there is no issue with your cable. It could be to what's connected to your Mac computer. Its a class compliant device so there are no additional drivers to install. Make sure you don't have any other USB device connected to your computer besides the Alesis GuitarLink Plus. This is important because having multiple USB devices connected at the same could interfere with your current connection. Please confirm.

    You can also refer to this helpful Troubleshooting Class Compliant USB Computer Peripherals guide to help you out.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m tilted, FeelsBadMan
    Tried already, with only GuitarLink connected. I have conversation with another employee, but maybe you'll figure it out by reading this:

    My message:
    Hello. Recently I bought Guitar Link USB to record my guitar (Epiphone Les Paul Standard). I plugged it into my computer (MacBook Pro Retina 2015) and the problems started. First of all the interface was named as USB PnP Sound Device which was pretty unexpected. Then I installed Guitar Rig 4 and tried to play... The sound was awful, in fact you could clearly hear some beeping noises and really annoying tickling. I thought that there might be some issue with my power supply or some of that matter but no, even though I plugged of my computer, the same thing was happening. I tried to record RAW input file but similar situation occurred. I tried even using Garage Band but with no any progress. I contacted my retailer and brought cable to the store. The guy plugged it in and everything was fine with his setup (He had Sony Vaio notebook with Windows 10 and plugged the cord directly to the machine). Ah, and I found out that there were some drivers installed, but they didn't work at all (NIUSBAudio prefpane in system preferences), "no Native Instruments USB device connected". What else can I say... I tried the same thing with my old MacBook 2008 and even with MacMini from 2005, and it didn't work either. Tried to change guitar (sister's Epiphone SG) - no effects. To straighten things up. I'm not even mad at this point, but if you mark your product as compatible with Mac, it's just not fair with me as a costumer if it doesn't work properly with my computers. Please don't threat me as dumb person, i want to resolve this issue. If you want any more information i prefer to contact by e-mail.

    Response (Adam I):
    Thank you for your email.
    Further to your comments below I can see that you have had some issues with getting your device set up.
    Can I ask what you have your buffer settings at please( this is in the preferences section or audio set up section) ?
    Also can I ask if you had the metronome on when you were trying to use it as this would give the ticking sound that you have said about.
    Also with regards to the device working on Mac and how it shows on your computer, the device will show up as a USB PnP device and this is due to the device using your computers on board drivers.
    I believe that the issue that you are having is latency related and as such will only be resolved by changing the buffer setting to a high latency such as 256 or even 512mbs.
    Please try this and should you have any further inquiries please don’t hesitate to ask and we will be more than happy to help.

    My message:
    I tried with all the setting you listed above, even tried to change audio format to 48 000Hz, it still makes the same noises and. As I mentioned, I recorded RAW file, which means that no program had impact on it, only core drivers (the Mac ones). Nevertheless, I can’t change buffer of my device in system drivers, only through Guitar Rig, and how does it supposed to control overall interface? For example if I wanted to use it with GarageBand.
    In windows, asio4all can controls it, moreover even the native drivers works flawlessly with this cable (yes again RAW file, heard from Audio Inputs menu without any interference). Just curious, do you have ability to try this cable out with similar setup as mine? I really want to confirm whether the drivers are working properly on these devices, cause I tried on every computer that I work with, and every single one had the same issues. (MacBook Pro 13’ 2013, MacBook Pro 15’ 2015, Mac Pro 2013, MacMini 2007, MacMini 2012) I installed provided drivers on every single one on these machines. Please, don’t treat me as a non-tech person, because it’s rather rare for me to contact companies with my problems that I can solve on my own.
    At this point I can’t do anything without voiding the warranty, and can’t confirm if the drivers are outdated or my machines are broken, but I think the second one is false, BECAUSE I RAN WINDOWS ON MAC (through BootCamp) AND CABLE WORKED.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I’m fucking pissed off
    I have the same issues with my GuitarLink. Followed the set up and as I monitor my raw input through my Mac. A beeping sound is heard, perhpas beeping 5-6 times per second. If I however alter the frequency from 44 to 48Khz the beeping is slower.

    I tried it on a PC and it worked. However I'd rather hang my self with this damn cable then use a PC. You state that it should work on a Mac (and I've tried 10.11, 10 and 9 and it beeps on all versions) so fix it.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Ted,

    Please see Chris D's response above. Can you please post a video so I can see exactly what's happening when the beeping occurs?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I've taken the steps shown in Chris D's response. Is there a mail I can send the video to?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned

  • In the past, customers have privately uploaded a video to Youtube and posting the link here to demonstrate the issue. You may also feel free to get in touch with your nearest Support Office, or contact support by logging on to www.alesis.com/support and selecting Technical Support from the drop-down menu, for further assistance.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m frustrated
    I'm having the same problems so I've made a video to show the issues. The description should cover all the details but I'm happy to give any specifics you need to try and sort this out. Just to be clear, I'm using Guitar Rig 5 standalone so it's not being hosted in a DAW and I have no other USB devices attached to my machine. The video is shot with the laptop using battery power to eliminate the possibility of a faulty power adapter causing the issue though I've tried with the laptop on mains power with no change.

    https://www.youtube.com/watch?v=HC9va...
    • view 1 more comment
    • I have the exact same issue! And what do you mean no sound? There is sound all over the clip, you can hear it drastically increased when he amp's the input up at 33 seconds into the clip.
    • Thanks for your reply Bill. I've looked at the video again and there is definitely sound on there. Maybe you didn't play it all the way through? At 33secs in, I turn on the effects and amp in Guitar Rig and the issue becomes VERY noticeable (as mentioned in the video description, perhaps you missed this too?)
      If you still can't hear the sound on the video it may be that you have a problem with your system - if you post the details on this forum I'm sure one of us will be able to help in getting your issues sorted!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I’m frustrated and disappointed
    Hi All,

    I am having the exact same issue as shown in the youtube video link by Leon. It's quite annoying a frustrating as I have spent a few hours looking for answers and instructions to fix the problem and couldn't fins any.

    I have a macbook pro with MacOS Sierra 10.12.1 and I am using Logic pro X 10.2.4 and also tried with guitar rig 5.1.0

    I followed the instructions from the quick-start guide several times.

    I have tried following this troubleshooting link, and there is no results.
    Troubleshooting Class Compliant USB Computer Peripherals
    http://www.alesis.com/kb/article/1619

    Also tried changing the buffer size to al possible options and the beeping is exactly the same in all of them. Also tried changing the 24bit recording option from Logic Pro X (as the guitarlink plus is only 16bit) and no change at all. Also tried changing the sample rate from 44.1kHz to 48kHz and the beeping changes to a slower frequency but it is still there and the noise is the same...

    I don't know what else can I try, so please any help will be very welcome.

    Thank you very much.

    Luis.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned

  • i have my pro 16, tried using RS cable but it only gave me static noise. Anyone here found a way out of this?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I’m frustrado
    I have no sound of my guitar rig 5 an the guitar link plus Alexis and also is recognize as USB PnP loud device
    a did no recommend Alesis products on Mac
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m frustrated
    I'm experiencing the same problem of pulsing beeping noise when connected with this cable with any electric guitar to Garageband on Macbook pro. Any solutions or answers to this widely recognized problem, Alesis?
    • view 2 more comments
    • Wow! I'm just giving the information, no need to be rude, mate. I got a refund in my local store after insisting a bit and showing them the problem, and bought the other one. I agree with you that Alesis should give a solution. At least I am giving you an alternative.
    • My apologies, I did not mean to offend. My poorly aimed frustration was meant for Alesis, not you. Thank you for helpfully offering a way to go about it, I'll try and see if my local store will be as accommodating as yours was. If only the producers of this product would bother to provide the solutions themselves instead of having leaving it between the buyer and retailer ;-)
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I get a beep every 30 seconds or so running guitar rig 5.2.2 on mac os x 10.11. Any idea how to stop this?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned