How do I get my Alesis Multimix 8 to work with my Windows 10 and NTrack 9 Studio recordings. Any help greatly appreciated

I am using a Dell Latitude E6410 laptop
I have windows 10
I want to record using my Alesis Multimix 8
My current software is NTrack 9.2

Is windows my problem when I changed to window 10 I have not recorded.
Now I have time and the NTRACK or something does not recognize my device.
Thank you for any guidance.
1 person has
this question
+1
Reply
  • Hi James,

    Thanks for posting. 

    Just to confirm, are you using the original MultiMix 8 USB, MultiMix 8 USB 2.0 or the MultiMix 8 USB FX? If you're using the 2.0 model, make sure that you have the latest driver for your mixer installed from the product page - https://www.alesis.com/products/view/multimix-8-usb-2.0. This will ensure that your mixer is properly recognized and properly communicates with your mixer. 

    Follow these steps below to properly configure your MultiMix with your computer:

    1. Use the included cable to connect the MULTIMIX 8 USB to your computer.
    2. Go to Start Menu > Control Panel > Hardware and Sound > Sound.
    3. Click the Playback tab and select USB Audio Codec* as the default device.
    4. Click the Recording tab and select USB Audio Codec* as the default device.
    5. Click Properties in the lower right-hand corner.
    6. In the new window, click the Advanced tab and select 2-channel, 16-bit, 44100 Hz (CD Quality) as the default format.
    7. Uncheck both boxes under Exclusive Mode.
    8. Click the Levels tab and set the slider to "4."
    9. Click OK to close the Properties window.
    10. Click OK to close the Sound control panel.

    After configuring your mixer using the settings above, set the Multimix as the input and output device within your DAW software. 

    I hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated indifferent, undecided, unconcerned