I’m frustrated

How to remove a global reverb (or echo) effect on DM10 Module?

How to remove a global reverb (or echo) effect on DM10 Module? The reverb effect is very pronounced (i.e. it's incredibly annoying) and occurs even after a factory reset, and doesn't matter which drum kit is selected. If you edit a drum kit settings, and reduce reverb to zero for each drum head, the reverb is still there, as pronounced as ever.
2 people have
this question
+1
Reply