Master Control not showing on firewire bus, numbers on bootup

I have a master control that has issues appearing on the firewire bus. It hardly ever shows up in the system profiler on mac, thus fails to connect. I've tried it on a number of 2008-2012 macs without success. It was showing up on a 2009 macbook several times and was working fine but can't get it to show at all now. Any ideas? Also does anyone know what the numbers are that flash up on the display on bootup, I've seen a number 1, 2 and 3 show up on the display immediately after hitting the on switch, then goes into the usual boot procedure.
1 person has
this problem
+1
Reply
  • Hello,

    Thanks for posting. We value you as a passionate and loyal customer. Your product is one of our discontinued Legacy products. Please check online with third party forums, third party websites or you can contact our tech support team regarding your Legacy product for assistance. Please keep in mind, support for Legacy products is limited as we mainly support our current in-line products.

    Alesis Industries World Headquarters (United States Office)
    Support Contact: 401.658.3131

    Alesis UK LTD (United Kingdom Office)
    Support Contact: +44 1252 896040

    Alesis GmbH (Germany Office)
    Support Contact: +49 2154-81299-20/-25

    Alesis Japan Corporation (Japan Office)
    Support Contact: +81-3-6277-2231
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated