no sound

I just set up my electronic drum set. It can play preset songs just fine however the pads itself are not making any noise?? Why?

email: machass1738@gmail.com
1 person has
this problem
+1
Reply
  • Hello, Mac

    Thanks for posting! 

    Sorry to hear you are having trouble setting up your kit, which electronic kit do you have? Make sure that all of the pads have the cables fully inserted into the pads, that would be the only reason you are getting output from the songs and not the pads. If the cables are plugged in correctly and you still do not receive any output, please contact our support team. 

    The USA Support Office is open Monday - Friday,8:30 am - 6:30 pm EST (not including holidays or weekends) and can be reached at 401-658-3131

    If you'd like, you may also contact us by submitting a support request:

    Hope this helps!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • I’m Beyond happy
    1
    Hi Criss. It was just a plug in issue. Lol. Im ashamed. However it was 2 am when I posted that and I had just spent the past 3 hours setting up the kit. Got it working in the morning. Anyways, I appreciate you replying to my comment. I didn't think anyone would read that.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated