I’m pissed

No sound from the drum kit with headphones or speakers

I just got a new alesis nitro kit and i don't have any sound from the drums. I got it to work a few times by pressing random buttons but now I can't figure it out. I have headphones plugged in and I tried speakers as well. It registers that my pads are being hit but there is no sound. Everything is plugged in fine.
1 person has
this problem
  • Hello,

    Thanks for posting. Sorry you're having issues with your Nitro Kit. 

    Have you tried performing a reset on your module to see if this fixes your issue? To do this, hold the < and > arrow buttons simultaneously while powering on the unit. The screen will show "RST---" for one second and then the module will restore back to the factory default settings and be ready to use.

    Let me know how this goes. 
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited