Problem with screen on alesis forge

Hi all my has Screen gone cloudy on the forge module one minute it was fine next time I turned it on the screen had gone cloudy I can just about see it looking normal at it but if I look from the side the screen appears as its supposed to. TIA
1 person has
this problem
+1
Reply
  • Hello,

    Thanks for posting. Sorry you're having issues with your module.

    Can you please confirm the specs of the power supply you're using with your module? If you're in the US, you should be using a 9VDC 500mA pin positive power supply.

    If you're using this type of power supply with your module and you're still having issues, you may need to service your module.

    Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alesis Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated