I’m frustrated

SR18 not saving user patterns

My SR18 won’t save user patterns anymore. I am set to “Pattern/User”, scroll to an empty number, select Record Setup. Then I change the name and length, and exit the menu by pressing the Record Setup button again.

Nothing gets saved. The name goes back to Empy Pattern and the length to whatever it was.

I’ve tried this 1000 times. A,B,and Fill are all empty. I’ve also tried saving the new Pattern with the “Saving a Pattern” after the Record Setup, and it still doesn’t work. I’ve also tried Factory Resets.

I see from the forums that a lot of people have this problem. I’ve reached out to technical support but haven’t heard back yet.

Any have any possible solutions?

Thanks!
1 person has
this problem
+1
Reply
  • Hi Thom,

    Thanks for posting. Sorry you're having issues with your SR18.

    It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alesis Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited