Strike Pro Kit, Snare not producing sound properly.

Strike Pro Kit: Snare: Seems like sensors are the electronic card is damaged. I plug the snare cable onto another tom and it worked/sounded properly. Are the sensors damaged? Does it have a simple solution, such as doing a good cleaning in the inside? Please advise.
1 person has
this question
+1
Reply
  • Hi Adrian,

    Thanks for posting. Sorry you're having issues with your Strike Pro Kit.

    It sounds like you may need to replace the snare pad that came with your kit. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alesis Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Could you please tell me more about which specific part we are talking about? English is not my native language, this could some language issue and I am not sure what you mean about the snare pad is. Thanks
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned