I’m confused

Strike ride cymbal not triggering properly

I'm having an issue with the ride cymbal on my Strike kit. The bow and bell only trigger if struck hard with the middle of my stick, not just the tip. The edge triggers more easily, yet all 3 zones only seem to work in one small area, not spread out like normal. I did try connecting it to a Roland TD-11 module with its supplied cables and had no issues, meaning my cymbal is working fine. I then tried connecting a Roland ride cymbal to the Strike module with the Strike's cables and it worked fine, so I'm not sure what's causing the problem. I have tried adjusting all kinds of settings on the module but they make no difference. All other pads work fine.
1 person has
this problem
+1
Reply
  • Hello,

    Sorry you're having issues with your Strike Pro Kit. 

    Have you tried performing a factory reset on the module? To do so, please follow these steps below:

    1. Turn off the module.
       
    2. Press and hold the Stop and Enter buttons while powering up the module. "Resetting Factory Defaults..." will be displayed on the module.

      strike pro reset procedure
       
    3. Wait 5 seconds, then let go of the buttons.
       
    4. That's it! Your Strike Module has now been restored to the factory default settings! After performing the reset, give the samples about a minute to reload properly.

      Note: Samples and User kits will not be impacted by this procedure since the files are saved on the external SD card.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • I tried the reset idea and still no sound from the ride.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned