I’m confused

the alesis 49 is no longer recognized by my mac. it has just stopped working.

The system was working fine the one day i plugged it in to my mac as usual and it was no longer functioning. It was getting power but neither the keys or drums were working. My roommate tried on her computer too. it did not work either. i tried a different usb cable too, but no change.

Any suggestions would be appreciated.
1 person has
this problem
+1
Reply
  • Hi Ronald,

    Sorry you're having issues with your product.

    It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alesis Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited sad, anxious, confused, frustrated