V49 not connecting

I am having issues when connecting the V49 to my Macbook Pro and my daughters MacBook air. It connects and the keys light up but the mac's either do not see it or i get a message saying unplug the device as it is drawing too much power. I have found that if you touch the lead by the connector on the V49 all the lights flicker on and off. I have changed the lead and the same happens so I think the connector is faulty. Can you replace the jackboard and if so does anyone know where i can get one. I have searched for a VSeries_Jackboard V0.9_20140606 but not having much luck.
1 person has
this problem
+1
Reply
  • Hi Stuart,

    Thanks for posting. Sorry you're having issues with your V49.

    It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alesis Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited