Album player controls not visible

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
When I view an album, the sample playback controls are not shown:



If I hover over the space where the controls should be, I see a mess of icons there:



If I click the space, the sample playback begins, but the UI is still not correct:



Additionally, there's no indication of *which* sample is currently playing.

I'm using the latest version of Google Chrome with the latest version of Mac OS X.
Photo of sloanlance

sloanlance

  • 20 Posts
  • 1 Reply Like
  • frustrated

Posted 6 years ago

  • 1
Photo of Chrysta Cherrie

Chrysta Cherrie

  • 731 Posts
  • 9 Reply Likes
Thanks for the screenshots. Those are helpful. You do have Javascript enabled, correct?
Photo of sloanlance

sloanlance

  • 20 Posts
  • 1 Reply Like
Yes, JavaScript is enabled. This is with Google Chrome Version 28.0.1500.71 and Mac OS X 10.8.4. The only extension installed in Chrome is Web Developer version 0.4.3. However, if I disable or uninstall that extension, it makes no difference. The page still looks as shown in the screenshots.
Photo of Chrysta Cherrie

Chrysta Cherrie

  • 731 Posts
  • 9 Reply Likes
Thanks, it's helpful to be able to rule that out. We're working on it.
Photo of sloanlance

sloanlance

  • 20 Posts
  • 1 Reply Like
I just thought of looking at the browser's console. There are several messages there.

These are the errors:

GET http://www.allmusic.com/images/row_pi... 404 (Not Found) kind-of-blue-mw0000191710:783

Blocked a frame with origin "http://view.atdmt.com" from accessing a frame with origin "http://www.allmusic.com". Protocols, domains, and ports must match.

Blocked a frame with origin "http://view.atdmt.com" from accessing a frame with origin "http://www.allmusic.com". Protocols, domains, and ports must match. dvtp_src.js?ctx=607671&cmp=CINGCIN15501CNT&sid=429765940&plc=429765940&num=...940&btadsrv=atdmt&crt=&crtname=&chnl=&unit=&pid=&uid=&dvtagver=6.1.src:310

7 Blocked a frame with origin "http://view.atdmt.com" from accessing a frame with origin "http://www.allmusic.com". Protocols, domains, and ports must match. dvtp_src.js?ctx=607671&cmp=CINGCIN15501CNT&sid=429765940&plc=429765940&num=...940&btadsrv=atdmt&crt=&crtname=&chnl=&unit=&pid=&uid=&dvtagver=6.1.src:308

Blocked a frame with origin "http://view.atdmt.com" from accessing a frame with origin "http://cm.g.doubleclick.net". Protocols, domains, and ports must match. dvtp_src.js?ctx=607671&cmp=CINGCIN15501CNT&sid=429765940&plc=429765940&num=...940&btadsrv=atdmt&crt=&crtname=&chnl=&unit=&pid=&uid=&dvtagver=6.1.src:308

These are log messages:

Resource interpreted as Font but transferred with MIME type application/octet-stream: "http://www.allmusic.com/assets/webfon...". kind-of-blue-mw0000191710:54

Resource interpreted as Font but transferred with MIME type application/octet-stream: "http://www.allmusic.com/assets/webfon...". kind-of-blue-mw0000191710:54

Resource interpreted as Font but transferred with MIME type application/octet-stream: "http://www.allmusic.com/assets/webfon...". kind-of-blue-mw0000191710:54

Resource interpreted as Font but transferred with MIME type application/octet-stream: "http://www.allmusic.com/assets/webfon...". kind-of-blue-mw0000191710:54

I hope this info can shed more light on the problem.
Photo of Dan T.

Dan T.

  • 0 Posts
  • 0 Reply Likes
Hey Lance,

I'll bet you have a retina MacBook, right?

I think I see the issue. We should have a fix out for this soon.

Thanks!
Photo of sloanlance

sloanlance

  • 20 Posts
  • 1 Reply Like
Yes, it is a Retina display. Is that making the positioning and sizing of your graphics not appear correctly? Shortly after I got this computer, I noticed the graphics in some of the web applications I developed don't look very good, either.

Also, is there any solution for displaying which sample from an album is currently playing?
Photo of Zac Johnson

Zac Johnson, Official Rep

  • 3334 Posts
  • 189 Reply Likes
Hey Lance, we've rolled out our fix.
Are you seeing the proper graphics on your retina display now?
Photo of sloanlance

sloanlance

  • 20 Posts
  • 1 Reply Like
The player controls are much better than they were before.

However, it still doesn't indicate which track from the album is currently playing.

I've also just noticed that the player allows multiple tracks to play simultaneously. The old way was better, stopping the currently playing track whenever a new track is started.
Photo of Chrysta Cherrie

Chrysta Cherrie

  • 731 Posts
  • 9 Reply Likes
Glad the controls are working for you. We're aware users would like to have back those features you mentioned and are working on it. Thanks!
Photo of sloanlance

sloanlance

  • 20 Posts
  • 1 Reply Like
Hi, Chrysta.

Thanks for the confirmation. Is there another topic here on Get Satisfaction about the AllMusic website simultaneous playback and track indicator? If there is, could you tell me the link to it? I'd like to follow/+1 it, too.

Other than that, I think this issue about the album player controls' visibility is resolved.
Photo of Chrysta Cherrie

Chrysta Cherrie

  • 731 Posts
  • 9 Reply Likes
The other place on GetSat where this has been mentioned is here: https://getsatisfaction.com/allmusic/..., otherwise we've gotten various mentions of it through our other feedback channels (blog, email, Facebook, Twitter).
Photo of Zac Johnson

Zac Johnson, Official Rep

  • 3334 Posts
  • 189 Reply Likes
Hi Lance.

We just rolled out a new feature that does a couple of things:

1. Playing a different sound sample pauses the one that was already playing.
2. Hovering over the album-level sound sample player will display the title of the song that is playing back.



Let us know if this solves your issues.
Hopefully we were able to take care of this for you.