Humans

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
The TV shows Humans has been appearing on my calendar but not below in 'Your Tracked Shows'.  So, there have now been three episodes that I haven't been able to tick off that I've watched.

Just FYI.
Photo of spades.dj

spades.dj

  • 20 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Alex

Alex

  • 4789 Posts
  • 192 Reply Likes
Hi there!
Is your tracker set to only display 'Current' shows? I know it's not ideal, but our site uses US air dates by default, even if the show airs first elsewhere, so it is still being considered as on 'Hiatus'. If you switch your tracker to display 'All' shows, it should appear! Sorry for the confusion.
Photo of spades.dj

spades.dj

  • 20 Posts
  • 0 Reply Likes
Hi Alex,

Thanks for your reply, however, my tracker is always set to 'All' and Humans still doesn't show up there, only on the calendar.
Photo of TV Queen

TV Queen, Official Rep

  • 8230 Posts
  • 876 Reply Likes
If you uncheck 'Hide Up-To-Date Shows' and scroll down to Humans, the episodes will be under the 'Unwatched' tab.

Alternatively, you can click the episode title on your calendar and mark the episode as watched in that fashion.
Photo of Alisa Acuna

Alisa Acuna

  • 81 Posts
  • 0 Reply Likes
Hello! It appears that Humans is showing an episode behind. Episode 8 aired this past week. 
Photo of TV Queen

TV Queen, Official Rep

  • 8230 Posts
  • 876 Reply Likes
Thanks for letting us know. Looks like they decided to run a double-header on the 17th instead. 

Updated now.
Photo of Alisa Acuna

Alisa Acuna

  • 81 Posts
  • 0 Reply Likes
Does it take time to update? I am still showing the 24th as the airdate for episode 8
Photo of TV Queen

TV Queen, Official Rep

  • 8230 Posts
  • 876 Reply Likes
It should have updated by now.



Please try clearing your cache and/or restarting your browser, and see if that gets it unstuck.
(Edited)