Alto Black 10 - annoying low level high pitched hiss.

I know that the Black series has been discontinued, but I have 3 pairs. 2 sets of 10's and one set of 15's. I'm hoping with all I have invested, they would take me into the future for a few years. I'm using 1 of the sets of 10's in my studio for client playback monitors. One of the speakers has developed a quiet, but annoying high frequency hiss. These are already noisy amp modules, but I was wondering if anyone else has had this specific problem. I've tried swapping the speakers around, to see if it is a grounding or power cable issue, but the noise is specific to that one speaker and is there no matter where it is at. No input, amp turned down, doesn't matter. Playing music back at low volumes does not affect it - still there at the same frequency (around 8k i would say) and volume. Thanks for your help.
Adam
1 person has
this question
+1
Reply
  • Hi Adam,

    Thanks for posting. Sorry you're having issues with your Black 10s.

    If your speakers are hissing with the volume all the way down and nothing connected, this sounds like it may be a hardware-related issue, and your speakers would need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alto Pro Audio Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated