Alto TS115A - No Bass

Speaker Tweeter working, No Bass.
Any ideas?

May have had a dodgy speaker lead causing bass not to work anymore.

Any Ideas?
1 person has
this problem
+1
Reply
  • More than likely the 15" driver has overheated and blown, a close friend of mine bought 4 of these cabs and thought his system was powerful enough to cope with 250 people but obviously not, so he brought them up to me to see how we can improve on them, I removed the loudspeaker on one of the cabinets and NOT to my surprise can see how easy it would be to improve on by just changing the loudspeaker driver, we choose an Eminence Kappa-15A ok its a lot more cost @ £110 compared to what Alto use which is a low cost unit probably around £50. The difference was worth the cost, we put 2 cabinets along side each other, the Eminence loudspeaker was more than twice as loud and can handle a lot more power whereas the alto standard driver didn't stand a chance, ok it will weigh a bit more because it has a larger magnet but will last a lot longer. If you don't want to spend the money just replace the cheaper driver and be careful when driving hard, another suggestion would be to add two 18" active subs and turn down the bass on the TS115A's and then you will have a far better set up and then you have a 3 way active P.A. system.
    I have been running and improving sound systems since 1977 so in my opinion a two way (Bass & Horn tweeter) loudspeaker cabinet is a compromise and I would only use them for monitoring, the least would be a 3 way or better still a 4 way set up Sub Bass up to 100Hz, Bass from a 100Hz to 250Hz, Midrange from 250Hz to 2kHz and the horn tweeter for your high's 2kHz to 20kHz (if you can hear that high) these crossover frequencies are a good guide only but once you have a 4 way system you will never go back to a 3 way or worse still a two way. Below is one side of my system. 21" Sub, 18" Bass 2 in no. 10" Mids and 2 in no. 1.5" compression horns in one cabinet running 4 stereo amplifiers and a 4 way active crossover
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Hi Sarah,

    Thanks for posting. Sorry you're having issues with your TS115A.

    It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alto Pro Audio Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • So i just bought this 12 from somebody....i tested at his house and everything work perfectly and now i get home and i get no bass out of it
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated