I'm having problems with my L-12 main output in both RH and LH channels

Having problems with RHS output not working and now LHS is becoming a very low output. The unit is a L12 12 channel compact integrated live sound mixer with digital effects. It was built round 2005. Any thoughts tech guys out there. Thanks Dave
1 person has
this problem
+1
Reply
  • Hello Dave,

    Thanks for the post. It seems like you may be working with one of our older legacy products. I can try my best to help you out but you didn't indicate which Alto Pro product that you're using. Could you inform us please?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hi Chris. Thankyou very much for your reply. I did not see your reply till now. Yes it is the old Legacy product and any help would be greatly appreciated as I was about to pull it apart tonight.
    Regards Dave
    • view 1 more comment
    • It's the L-12. Unpowered mixer. model no 4710945010335
      And serial 6030068026 sorry.
    • Hello,

      Thank you! Yes, this product is quite old. Support for Legacy product is quite limited as we mainly support our current line of products. You can find the latest information for this product on its product page - http://www.altoproaudio.com/products/....

      To help with your current issue, read carefully through the following information below. Not paying attention enough to the input signal level, to the routing of the signal and the assignment of the signal will result in unwanted distortion, a corrupted signal or no sound at all. So you should follow this procedure for every single channel:

      * Turn down all Input and Output Gain Controls.

      * Connect phantom powered microphones before switching on the +48Volt Phantom Power switch.

      * If you have a power amplifier connected to your L-12 set the Level of the amplifier at no more than 75%.

      * Now, set the CONTROL ROOM/PHONES level at no more than 50%. In this way you will be able to hear later what you are doing connecting a pair of headphones or a pair of powered studio monitor speakers.

      * Position EQ controls on middle position.

      * Position panoramic (PAN) control on center position.

      * With a headphone or studio monitor speakers connected apply a Line Level input signal so that the PEAK LED does not light up.

      * At this point increase the input gain so that the PEAK LED will blink occasionally. In this way you will maintain good headroom and ideal dynamic range.

      * Now connect a microphone and ask the singer to sing loud into the microphone. Turn slowly the Gain Control clockwise and have the PEAK LED blink only occasionally.

      * Now repeat the same sequence for all input channels. The Main LED Meter could move up into the red section.

      * In this case you can adjust the overall output level through the MAIN MIX control.

      If you need to service your legacy mixer, try contacting our Technical Support team. Non-warranty claims are not handled here on the forum but I can point you in the right direction to help you out! Here are a couple of options that you could choose from:

      • Submit a Warranty Claim or Service Inquiry with our Technical Support team by logging onto www.altoproaudio.com/support. Select Warranty Claim or Service Inquiry from the drop down menu.

      or

      • For quicker support, call your nearest Support Office or International Distributor. If you’re going with your International Distributor, simply select your country to contact them.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hi Chris,
    Thanks for your reply. I have solved the problem. I cleaned all the inputs with contact cleaner and an alcohol solution. I also cleaned the rear input board and around the bases of the capacitors then applied contact cleaner to all the pots and buttons. The unit appears to be working fine now.
    Regards Dave
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited