Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m super sad

TS312 12" Subwoofer - Doesn't power up

I've had two of these where for some reason they decide to not power up. One happened a few years ago at an event, the other one just a random Tuesday.

Everything working fine, then go to turn it on and no power. All other components fine, just the one speaker out of four that doesn't turn on. Seems like something had to blow.

Purchased new in April of 2019. Used regularly but not excessively.
1 person has
this problem
+1
Reply
  • Hello, Seth

    Thanks for posting!

    Sorry to hear that happened with your speaker. It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Alto Pro Audio Support Page. Select Warranty or Service Inquiry from the drop down menu.

    or

    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly