Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Smart recovery overwritten by the thermostat in Auto(heat/cool) mode. Lets fix this! Super easy and convenient!

I live in Texas. We only really use heat by late fall to early spring.

Iv'e been using the auto setting (heat/cool) on my Ecobee 3 for the past month or so, and I've noticed that now the cool smart recovery does NOT work. It now automatically goes by my schedule instead of cooling my bedroom down to the desired temperature in advance. This is super annoying!

I've as usual spent countless time on the phone with customer service, only to find out way too late that this is just how the thermostat works. After several "re-boots" and "waiting days" of course. I knew I was right all along(I know my system pretty well), but you gotta play "the game" with customer service of course. Apparently now, they say that smart cool recovery doesn't work in this setting because it would conflict with the heat setting. I call BS on this! It doesn't make any sense.

In the summer. It takes around 3 hours to cool my house down from 75 to 69, which is my preferred sleep temperature. I am therefore used to just wearing a hoodie or a blanket a couple house before bedtime when I sit in my living room watching TV, while the house slowly cools down. This is NOT a problem. So.... How would it be a problem to be a little chilly for only about 45 minutes before bedtime in the winter? It isn't a problem at all.

So. Lets make this recovery feature work all the time and not just sometimes! It makes NO sense and it's simply ridiculous that this one slipped though the hands of the development team. If the customer chooses a smart recovery setting, that setting should NEVER be overruled by the thermostat for any reason.

Solution: Simply fix the software so when in the auto(heat/cool) mode, it simply overrides the heat feature when smart recovery cool mode is chosen. It's THAT simple! This way there won't be a conflict with the heat trying to turn on when the temperature gets below the set heat point. As smart recovery cool mode engages, heat mode gets overwritten until the sleep setting has been reached. This way we avoid any conflict at all. Simple, so lets fix it!
1 person likes
this idea
+1
Reply
  • While researching I came upon this comment. I have exactly the same issue with my Ecobee 4

    I notice it's two years old and hasn't been fixed yet.

    Perhaps everyone that wants to use Auto, for the system setting. AND Recovery should make comments on Amazon's and Best Buys's customer reviews. If they start losing sales, maybe it'll wake Ecobee up.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • I didn’t know about that feature. Other thermostats have that feature where they preempt a change. I sort of worked around it by creating a “precool” or “prewarm” comfort setting about an hour before the change.


    But yes ideally when I have enough data to run “smart recovery” (which btw many other smart thermostats have without the fancy terminology) it should work obviously.


    Another thing is that I keep my heat really low like at 59F. I’ve used smart thermostats since 2012 and I’ve come to accept that you have to reprogram them seasonally.


    However what you’re saying is right. Let’s say it’s winter in Texas and I need mostly heat during the day. At night I still need it cool and want it to start cooling so I can sleep. It certainly helps that my HVAC is quick and I have a small space but not everyone has that setup.


    When smart recovery is engaged, only smart recovery should control the temperature. Because obviously in one or two hours you need 69F. They need to let us choose which is a priority and for most of us sleep is a priority.


    They will talk out both sides of their mouthes and say it cannot guess which you want. They would be right. Why not let us tell the darn thing. However if you have enabled smart recovery it’s obvious you want it to preempt changes as needed. If you wanted everything to stay within the set points for the exact duration you scheduled then you simply don’t use smart recovery. I don’t see why this is so hard for them to understand.

    I think fundamentally in choosing Ecobee we chose a product that caters to tinkerers. People who think in explicit instructions like a programmer. However I think most of us just want the in built smart features to be smart. We paid them. So it should just work for helping people achieve comfort as they designed it. Which they should have put the thought into. That’s why we paid them.

    I suppose we bought the wrong product as it seems they think the product’s real value is in how programmable it is. That’s why support sent us here. To see how much development action is going on here. I appreciate that it is. But really let the product out of the box work for people who don’t know or care to know how to sit and program every little thing about it.

    I am sure there is some way you can fetch the smart recovery data and create a scene or command and explicitly tell it how you want it handle the situation given that data. That’s wonderful. But what about us? I paid for it with the expectation that it works intelligently and reasonably without me digging into all this stuff.

    It’s getting to the point that to get reasonable obvious functionally you need to hire a programmer to get it to work for you. They are outsourcing the development of basic obvious functionality to the user. I mean they built in so why not use the data point in a way that is obvious to the lay user? They’ll say that if they do then it would mess with the tinkerers. Why not change the documentation and let them figure out how to program around that? This is a very consumer unfriendly product that seeks to please the tinkering crowd.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Having said all that. A precooling period about one or two hours before bedtime which disables heat and sets it explicitly into cool only mode would help that. Yes that in some sense disables the point of smart recovery which is to do that for you and know exactly how long it would take. It is suboptimal in that sense. The whole point being this “smart” thermostat would know how long it can keep you at a nice 75F before it needs to hit 69F by 11PM for your programmed bedtime. Even my former el cheapo Lux Geo would do that for me leave alone the Nest.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited