I’m irritated

First Child problem in data mapper

Data mapper is not working properly with XML.

When trying to map this result (view-source:http://wsf.cdyne.com/WeatherWS/Weathe...:

true
City Found
CA
Beverly Hills
Burbank

2012-04-16T00:00:00
4
Sunny

49
75

00
00

[snip]

Under Temperatures, I can get DayTimeHigh (last child) printed, but not MorningLow (first child). Likewise, I can get Daytime (last child) printed, but not Nighttime (first child).

I am using plain response mapping, no custom mapping. To easy you reproducing it, reproduction, feel free to look in this project: http://tiggzi.com/project/c1aeccfc-56..., I am hands off on it until receiving response on this issue.

Right now it is set at showing morninglow, daytimehight, and nighttime. Only daytimehigh. If deleting nighttime and mapping daytime to same text label instead, it shows.
2 people have
this problem
+1
This topic is no longer open for comments or replies.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • It still does not work for me, attaching some screen shots, maybe you can spot a flaw in the construction:

    The mapping:



    The widgets on screen:



    The resulting page after entering 12345 as zip:



    And the data:



    Feel free to give it a look:

    http://tiggzi.com/view/c1aeccfc-566f-...

    /)/ikolaj
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • I have, when reproducing the error about rest services and widget updates in data mapping, been able to print all children, so I agree that the problem is not related to first children in XML.

    I am pretty sure that I map the same way when it works for me, and when it does not. I do have some other events assigned, so perhaps the culprit lies there.

    I am not going to change my example project (referred to above) unless you tell me you have looked at it, or that you cannot (will not) go into that detail in your way of debugging ;)

    Cheers, /)/ikolaj
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated

  • Max Katz (Official Rep) May 08, 2012 18:06
    I tried again the service and mapping in a new project, I was able to print everything (Label Text is printed when there is no actual value):



    If you can tell me how to reproduce the problem, we'll definitely try it and fix it.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated