ionic3 error PluginStreetViewPanorama.java:88: error: cannot find symbol StreetViewSource.OUTDOOR : StreetViewSource?

i have got above error after build android in ionic3.i have tried each and everything but nothing is worked for me.i have tried below solutions but nothing worked for me?

Remove android then again add platform .
2.Change the google-play services version to 15+, 11+ as well as change according to new version that is mentioned in the play services?

Poject.properties

target=android-26
android.library.reference.1=CordovaLib
cordova.system.library.1=com.squareup.okhttp3:okhttp-urlconnection:3.10.0
cordova.system.library.2=com.android.support:support-v4:24.1.1+
cordova.system.library.3=com.android.support:support-v4:27+
cordova.system.library.4=com.android.support:support-v4:25.+
cordova.system.library.5=com.android.support:appcompat-v7:25.+
cordova.gradle.include.1=cordova-plugin-firebase/managment-build.gradle
cordova.system.library.6=com.google.android.gms:play-services-tagmanager:16.+
cordova.system.library.7=com.google.firebase:firebase-core:11.+
cordova.system.library.8=com.google.firebase:firebase-messaging:11.+
cordova.system.library.9=com.google.firebase:firebase-config:11.+
cordova.system.library.10=com.google.firebase:firebase-perf:11.+
cordova.gradle.include.2=cordova-plugin-mauron85-background-geolocation/managment-dependencies.gradle
# cordova.system.library.14=com.google.android.gms:play-services-location:16.+
cordova.system.library.11=com.android.support:support-v4:26+
cordova.system.library.12=com.android.support:appcompat-v7:26+
cordova.gradle.include.3=cordova-plugin-telerik-imagepicker/managment-ignorelinterrors.gradle
# cordova.system.library.17=com.google.android.gms:play-services-location:16.+
cordova.system.library.13=com.android.support:appcompat-v7:23+
cordova.gradle.include.4=cordova-plugin-telerik-imagepicker/managment-androidtarget.gradle
cordova.system.library.14=com.android.support:support-v4:26.+
cordova.system.library.15=com.android.support:appcompat-v7:26.+
cordova.system.library.16=com.google.android.gms:play-services-maps:15.0.1
cordova.system.library.17=com.google.android.gms:play-services-location:15.0.1

//build.grdle

buildscript {
repositories {

maven { url 'https://maven.fabric.io/public' } // Fabrics Maven repository from cordova-plugin-firebase
maven {
url "https://maven.google.com"
}
jcenter()
}

// Switch the Android Gradle plugin version requirement depending on the
// installed version of Gradle. This dependency is documented at
// http://tools.android.com/tech-docs/ne...
// and https://issues.apache.org/jira/browse...
dependencies {
classpath 'com.android.tools.build:gradle:3.0.0'
classpath 'com.google.gms:google-services:4.0.1' // google-services dependency from cordova-plugin-firebase
classpath 'io.fabric.tools:gradle:1.25.4' // fabric dependency from cordova-plugin-firebase
}
}

// Allow plugins to declare Maven dependencies via build-extras.gradle.
allprojects {
repositories {
configurations.all {
resolutionStrategy.eachDependency { DependencyResolveDetails details ->
def requested = details.requested
if (requested.group == 'com.google.android.gms') {
details.useVersion '11.8.0'
}
if (requested.group == 'com.google.firebase') {
details.useVersion '11.8.0'
}
}
}
google() // Google's Maven repository from cordova-plugin-firebase
maven {
url "https://maven.google.com"
}
jcenter()
}
}
1 person has
this problem
+1
Reply