Why are the gradle files missing from my Android Studio export when I use V5.0 libraries?

I updated my app to V5.0 libraries. Now when I export it as an Android studio project, there are now gradle files included. Why?
Any help would be appreciated,
1 person has
this question
+1
Reply
  • Hello,

    Please check a folder "platforms\android" in the root of your project archive. The gradle file is there
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I will thanks, Android Studio was not able to find it.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • When I open the project in Android Studio with the V5.0 libraries it no longer does a Gradle build. It says I need to migrate to Gradle. Do I need to open the Android Studio project differently than I did with the V4.1 libraries?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Please open the file:
    gradle/gradle-wrapper.propetries

    and write down there:
    distributionUrl=https\://services.gradle.org/distributions/gradle-3.3-all.zip

    After that you will get a suggestion to update the Gradle plugin, please refuse it
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Hello :-)

    I have tried almost the same as Oldestman57. I get this when I try to make a signed APK.


    What is it best to do now ? The system will not let me make this APK.

    Ole Henrik Oftedal
    Norway
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I read here on this forum that I must run the build.bat file. I will try that later.
    Maybe that will help.

    https://getsatisfaction.com/apperyio/...

    EMPLOYEE
    Serhii Kulibaba (Employee) 1 month ago
    Please extract your project from the .zip file
    Open the folder \platforms\android\cordova
    Run the build.bat file

    Now you can open it in the Android Studio. Pay attention, you haven't to open it before running build.bat file
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Sure. It didn't go so well. But never mind. Only a small subset of our customers are using http instead of https. So I will instead help them to convert to https. So NO STRESS!!!

    But for the record I can mention:

    I use Mac and have installed JDK 8 and Node. I have also tried to update (EXPORT) the environment variable like this:

    export JAVA_HOME=`/usr/libexec/java_home -v 1.8`

    I make this variabel permanent in the most used shells.
    Then I exit all terminals and start the build script (in the same folder as build.bat)

    I get:

    Last login: Wed Jan 15 22:38:26 on ttys000
    /Users/myuser/Desktop/TimeflexAppNo-4/platforms/android/cordova/build ; exit;
    myuser@MacBookProCertholder ~ % /Users/myuser/Desktop/TimeflexAppNo-4/platforms/android/cordova/build ; exit;
    Checking Java JDK and Android SDK versions
    ANDROID_SDK_ROOT=undefined (recommended setting)
    ANDROID_HOME=/Users/myuser/Library/Android/sdk (DEPRECATED)
    CordovaError: Requirements check failed for JDK 8 ('1.8.*')! Detected version: 13.0.1
    Check your ANDROID_SDK_ROOT / JAVA_HOME / PATH environment variables.
    at /Users/myuser/Desktop/TimeflexAppNo-4/platforms/android/cordova/lib/check_reqs.js:371:19
    at _fulfilled (/Users/myuser/Desktop/TimeflexAppNo-4/node_modules/q/q.js:854:54)
    at /Users/ofto/Desktop/TimeflexAppNo-4/node_modules/q/q.js:883:30
    at Promise.promise.promiseDispatch (/Users/myuser/Desktop/TimeflexAppNo-4/node_modules/q/q.js:816:13)
    at /Users/myuser/Desktop/TimeflexAppNo-4/node_modules/q/q.js:624:44
    at runSingle (/Users/myuser/Desktop/TimeflexAppNo-4/node_modules/q/q.js:137:13)
    at flush (/Users/myuser/Desktop/TimeflexAppNo-4/node_modules/q/q.js:125:13)
    at processTicksAndRejections (internal/process/task_queues.js:76:11)

    Conclusion: I am struggling to set environment variables in Mac. Or I am using the wrong script. Or maybe wrong shell.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited