window.open no longer working in ios10.2

I have a published app where I recently made a minor update and published the new version of the app. I have buttons that use either:

window.open(the_link, '_blank','location=yes');
or
window.open(the_link, "_system");

Now on iOS 10.2, when you click the button you get the spinner for a split second, then nothing. No windows open on the device. Neither "_system" nor "_blank" works on iOS 10.2.

Everything works fine on other devices (Android, etc.), but it doesn't work properly on iOS 10.2.

Using the Xcode Simulator, it appears the window may open but it's not in focus (it's in the background?) since I can hit the home button, then the app icon to relaunch the app and I now see the window.

I'm using the most recent library version 3.1. I even imported the most recent version of the Cordova InAppBrowser (1.6.2) but it didn't improve things. I did try things on an older version of iOS (9.3) and it worked there, but it doesn't work on iOS 10.2.

I also tried a "virtual click" vs. "click" to no avail.

Any help would be appreciated.
1 person has
this problem
+1
Reply