Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Can't Install Boardmaker v6 on Mac OSX 10.11.1 El Capitan

I just got a new Mac running OSX 10.11.1, El Capitan. Every time I try to install the software, I am unable to do so and I receive this error message "You can’t open the application “Boardmaker v6 Installer” because PowerPC applications are no longer supported." Is there a work around for this? Thank you.
3 people have
this problem
+1
Reply