Help get this topic noticed by sharing it on Twitter, Facebook, or email.

I cannot install High Contrast PCS on my computer

It keeps saying that there is no compatible Boardmaker version detected. I have version 6.1.6 Any ideas why?
1 person has
this question
+1
Reply