Fullscreen mode on second monitor

  • Problem
  • Updated 6 years ago
On Windows Vista x64, cannot move boxee fullscreen to my second monitor. Read in forums that this was possible, but it is not listed as an option under Settings > Appearance > Screen.
Photo of Rick Cecil

Rick Cecil

  • 12 Posts
  • 2 Reply Likes
  • frustrated

Posted 7 years ago

  • 44
Photo of DARKFiB3R


  • 23 Posts
  • 2 Reply Likes
I haven't tested this out yet yon my current setup, but the ability to run full screen on any monitor is a must for me.


C2D 2.4GHz / 2GB / GeForce 7600 GT / Vista 32bit / Zalman HD160XT / Sony 46" 1080p / Harmony 895
Photo of

  • 3 Posts
  • 0 Reply Likes
Running Vista x32 and need the ability to select whether Boxee runs to the attached screen or to an external monitor.
Photo of

  • 5 Posts
  • 5 Reply Likes
This is an issue with the way XMBC reads resolutions. XMBC/Boxee initially copy over all the resolutions from your primary monitor. When I switch my primary monitor to my external display and run the application, everything works fine and I get the right resolution.

The way to fix this would be to allow custom resolutions. This can't be too hard!
Photo of

  • 3 Posts
  • 0 Reply Likes
So, it looks like there are two things that need to happen - XBMC/boxee needs to understand there's a second monitor (and read its resolution) and then either prompt for which monitor to run on, or provide a setting for a default.
Photo of

  • 5 Posts
  • 5 Reply Likes
Yes, and this should be done before the actual launch of the application. Maybe the XMBC source doesn't need to get modified, but a launcher application should look and see what monitors you have and which ones Boxee should run on.

If you set it as default, it'll never pop up again, so the app. would be pretty seamless. It would have to just fool XMBC into thinking that the monitor you select is the primary one. Below is a mock-up of what I had in mind.

Photo of Gail Kapusnick

Gail Kapusnick

  • 3 Posts
  • 0 Reply Likes
I had this problem and finally got it to work in Windows Vista. I have a Toshiba laptop which has its own control panel for displays. I hit the "connect external display" button, where it then asks me if I want to mirror the desktop, extend the desktop or use the external monitor only. I choose "Mirror desktop". At which point I get an unsupported resolution error on the TV screen. (and my laptop display looks weird too) Then I go into Windows Control Panel, go to Display options and click on monitor 2. I then check the box that says extend my desktop onto this monitor. At which point my tv screen starts working again. I then change the resolution on monitor 2 (the TV) to 1360x768, which is the best I can do with my laptop. Then I start Boxee, and under the resolutions choices I now get Fullscreen 1360x768 #2 as a choice. Click apply and it works perfectly. It does not seem to work if I don't go through the Toshiba control panel first. It was a giant pain to figure out, and is more trouble than it should be, but it seems to be either a Toshiba or Windows problem and not boxee. It was worth it, I'm really enjoying my music with trippy visualizations playing fullscreen right now.
Photo of Abed


  • 15 Posts
  • 3 Reply Likes
Also have this problem with both x32 and x64 Windows 7 Ultimate!

I need to go into windowed more drag the window to the second screen and then hold onto the "windows key" and press up.
Photo of marcel

marcel, Official Rep

  • 59 Posts
  • 12 Reply Likes
Please try this ..

1 Run Boxee.
2 Go to Settings > Appearance > Screen.
3 For Resolution, choose Full Screen #2.
4 Click on Test Resolution.
5 Boxee should run full screen on the secondary screen.
Photo of ben.bob


  • 5 Posts
  • 0 Reply Likes
The problem is that boxee stays at the first screen when it is started again. Although the screen selection is on full screen 2, I have to choose full screen 1, apply, choose full screen 2 to move it to move boxee to the second screen.
Photo of StevenR


  • 35 Posts
  • 9 Reply Likes
That is a bug in Boxee - there is an issue about it posted on the JIRA site (see here). The workaround at the moment is to switch to windowed mode and back to fullscreen after starting Boxee - the easiest way to do this is to press the backslash (\) key twice (I have a button on my remote mapped to do this until this is fixed).
Photo of Yir


  • 1 Post
  • 0 Reply Likes
You can use ultramon to start boxee and it will move boxee to the right screen (takes a few seconds), but works nice for your remote/mouse shortcut.
Photo of Jr. Hames

Jr. Hames

  • 1 Post
  • 0 Reply Likes
This is the only reason why I not moved from MediaPortal to Boxee yet.