How do I enable https?

  • Question
  • Updated 4 years ago
I seem to be flooding this forum with questions :-P

I see that I have a https directory and I am trying to view my content over a secure SSL/TLS connection. However no matter which browser I use they all throw an error when I enter my https://foo.bar.vc.catn.com URL:

Firefox: SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

Safari: Safari can’t establish a secure connection to the server

Chrome: Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.

Is there a CatN vCluster primer on using https?

Thanks!
Photo of DominicD

Dominic

  • 12 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of mark

mark, Employee

  • 6 Posts
  • 0 Reply Likes
Hi Dominic,

By default https is not enabled for vClusters, however it is available. If you need it then please contact sales and we can supply a certificate for you.

In future we plan to offer SSL by default based on a wildcard certificate but this has not been implemented yet.

Hope this helps,

Mark
Photo of DominicD

Dominic

  • 12 Posts
  • 0 Reply Likes
Thanks Mark.

I already have a SSL cert which is valid for another year.

Can I bring it on over?
Photo of DominicD

Dominic

  • 12 Posts
  • 0 Reply Likes
Ping!

Is it possible to use an existing SSL cert if I have one already?