I’m frustrated

Trying to capture Keynote presentation prototype

I am using Silverback to capture user testing sessions evaluating a clickable prototype built in Keynote. While recording, Keynote is running in presentation mode, allowing the users to click on links to other slides within the presentation.

I ran a quick test (around 1 minute in length) using this method and found that Silverback was able to record everything (Keynote in presentation mode, mouse clicks, user video and audio) just fine. The only slight issue I noticed is another version of the mouse pointer being constantly displayed where the "Play" button is in the top left of the Keynote interface, but I can live with this.

My issue is, now I have gone back through my full user sessions (about 45 minutes in length) to find that while everything has recorded ok, the actual prototype presentation I was displaying in Keynote does not seem to be present at all. The user video and mouse clicks have recorded just fine, but there is only a blank black space where the Keynote presentation should be.

Does anyone have a solution for this, or have I just lost everything and shouldn't be using Silverback with Keynote in the first place?

thanks!
1 person has
this question
+1
Reply
  • Hi Vincent,

    Really sorry to hear you've been having problems with Silverback. While Silverback hasn't been designed specifically to work with Keynote, Games and other apps that pop open a separate display layer on top of the regular desktop view, we have seen them work successfully in the past. Considering the test worked but the live session didn't, was there any difference between the two? For instance, during the live test did you have multiple monitors set up, change the display setting or use a different machine?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Hi Andy,

    Thanks very much for your response. Both the test and the live version were on the same machine (MacBook Pro, 2.53Ghz Intel Core 2 Duo), however there *was* a difference between the sessions.

    In the test session, I was running an additional monitor with the Keynote presentation running on the external monitor. The external monitor was the "main" monitor (the one with the OS X tool bar at the top of the screen)

    In the live session, I was running only off of the laptop with no additional monitor.

    I have just quickly rerun the test with both monitor configurations to find the following:
    The Keynote presentation records normally in Silverback when using multiple monitors.

    The Keynote presentation is not recorded in Silverback when using only the laptop monitor. Audio and video of the user as well as mouse movement and clicks still record, it's just the display of the actual Keynote presentation that is not visible.

    So, while not solving the problem, at least I know what the issue is now and I know how to avoid it in the future.

    Thanks for your help and hopefully there's a way to handle this issue in a future release of Silverback.
    • Hmm, that is strange. If anything I would have through that you'd have had problems on the dual monitor set-up rather than the single monitor situation. I wonder if the fact that you had it running on a dual system and then moved to a single screen set-up had anything to do with things. Could you try shutting Silverback down and then re-launching it in the single monitor situation, making sure that the display prefs are showing just a single monitor and that Keynote is showing in Primary display mode.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Yes, I agree, I would've thought the issue would be in the dual monitor set up as well.

    I tried everything as you suggested and even repeated the test with the Alternate Display option in Keynote preferences de-selected and still had the same results. When running Keynote in presentation mode on the MacBook Pro monitor only, the Keynote presentation does not record in Silverback. With dual monitors, it seems to work ok. Strange indeed!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m confused
    I just tried this as well (on a MBP, no external monitor) and had the same problem as Vincent. Has there been any other solutions found to this problem other than using an external monitor during testing? That isn't really an option for me.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m disappointed and frustrated
    I had the same problem recording 3 user sessions today with Silverback and prototype from Keynote. Running on OX Lion 10.7.2 and all recent updates; Flash prototype, user face, audio, screen outside presentation mode - everything is just ok; but it didn't records the keynote prototype in presentation mode.

    It worked for me on an iMac and without testing I just assumed the same behavior. I've lost 3 hours of user testing. Strongly considering other solutions instead Silverback.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • Same problem happened to me after a successful trial run on my dual monitor setup. Unfortunately I lost 2 user sessions before discovering this. I then converted the file to PPT and have had no problem since.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • To clarify, Victor, this is only happening which you are using the MBP? It's fine on the iMac?

    I'm able to reproduce this in some scenarios, so any information you have about setup, dual monitors, etc... would be great in helping us track down the problem.

    Regards,
    Andy.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited

  • I’m thankful
    Had the exact same problem, finally got it working through the following Keynote setting:

    Keynote > preferences > slideshow > "Allow Expose, Dashboard and others to use screen"

    Works, but (as they warn) a little bit choppy!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited